BackupBuddy

(Difference between revisions)
Jump to: navigation, search
(Multisite)
(Server Recommendations (full functionality))
(9 intermediate revisions by 3 users not shown)
Line 3: Line 3:
 
* '''Need hosting?''' ''Hostgator Coupons'' are available to BackupBuddy customers [http://ithemes.com/forum/index.php?/topic/14012-hostgator-coupons-for-our-community/ here].
 
* '''Need hosting?''' ''Hostgator Coupons'' are available to BackupBuddy customers [http://ithemes.com/forum/index.php?/topic/14012-hostgator-coupons-for-our-community/ here].
 
* '''[http://ithemes.com/codex/page/BackupBuddy_Multisite BackupBuddy Multisite Codex]'''
 
* '''[http://ithemes.com/codex/page/BackupBuddy_Multisite BackupBuddy Multisite Codex]'''
 
 
=Multisite=
 
 
As of version 2.2.14, BackupBuddy and Importbuddy include full BETA support for Multisite backups, imports and restorations.
 
 
[http://ithemes.com/codex/page/BackupBuddy_Multisite Check out the BackupBuddy Multisite Codex] and [http://pluginbuddy.com/purchase/backupbuddy/ Get BackupBuddy Multisite Beta Today!]
 
 
BETA indicates that Multisite functionality has known issues and is not reccomended for production use except at your own risk.  We do NOT guarantee its functionality or provide guaranteed support for beta products.
 
  
 
=Tutorials=
 
=Tutorials=
Line 39: Line 30:
 
===Server Recommendations (full functionality)===
 
===Server Recommendations (full functionality)===
 
* PHP 5.2+
 
* PHP 5.2+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2 currently requires PHP 5.2+]
+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2+ requires PHP 5.2+]
 
* mySQL 5.x+
 
* mySQL 5.x+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2 currently requires mySQL 5.0.15+]
+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2+ requires mySQL 5.0.15+]
* WordPress 3.1+  
+
* WordPress 3.3+  
 
* Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
 
* Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
 
** Backups will be stored in /wp-content/uploads/backupbuddy_backups/
 
** Backups will be stored in /wp-content/uploads/backupbuddy_backups/
Line 50: Line 41:
 
** PHP exec() function enabled
 
** PHP exec() function enabled
 
** PHP ZipArchive class installed
 
** PHP ZipArchive class installed
* Linux:
+
* Linux (Apache):
 
** Command-line zip installed and accessible via exec().
 
** Command-line zip installed and accessible via exec().
 
* Windows (only supported for local development via Apache; IIS is not officially supported):
 
* Windows (only supported for local development via Apache; IIS is not officially supported):
Line 56: Line 47:
 
*** You must have the ability to configure your server to allow execution of this zip.exe file for it to function.
 
*** You must have the ability to configure your server to allow execution of this zip.exe file for it to function.
 
*** File permissions must also be set to allow access and execution of the zip executable.
 
*** File permissions must also be set to allow access and execution of the zip executable.
* wp-config.php file must be in WordPress installation directory OR (starting with v3.0) in the parent directory.
+
* wp-config.php file must be in WordPress installation directory OR (starting with BackupBuddy v3.0) in the parent directory.
  
 
===Minimum Server Requirements (reduced functionality)===
 
===Minimum Server Requirements (reduced functionality)===
 
'' NOTE: Some features of BackupBuddy will be unavailable or limited if running on minimum requirements without recommendations. Large sites may not be able to be backed up with these minimum features.'''
 
'' NOTE: Some features of BackupBuddy will be unavailable or limited if running on minimum requirements without recommendations. Large sites may not be able to be backed up with these minimum features.'''
 
* PHP 5.2+
 
* PHP 5.2+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2 will require PHP 5.2+]
+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2+ requires PHP 5.2+]
* mySQL 4.x+
+
* mySQL 5.x+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2 will require mySQL 5.0.15+]
+
** [http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/ WordPress v3.2+ requires mySQL 5.0.15+]
* WordPress 3.0+
+
* WordPress 3.2+
** We are trying to maintain bare minimum backup functionality for legacy versions as far back as WordPress v2.6 (though it's not pretty nor guaranteed to work perfectly at this time).
+
** We are trying to maintain bare minimum backup functionality for legacy versions as far back as WordPress v2.6 (though it's not pretty nor guaranteed to work perfectly at this time; we recommend only performing backups & direct restores for older versions and use it for safety while upgrading to the latest WordPress).
 
* Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
 
* Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
 
* BackupBuddy requires the uploads directory to be in the standard WordPress location.
 
* BackupBuddy requires the uploads directory to be in the standard WordPress location.
Line 71: Line 62:
 
** Temporary files will be stored in /wp-content/uploads/backupbuddy_temp/xxxxxxx/ (temporarily generated at each backup)
 
** Temporary files will be stored in /wp-content/uploads/backupbuddy_temp/xxxxxxx/ (temporarily generated at each backup)
 
* Free disk space equal to or greater than the entire size of your site once compressed.
 
* Free disk space equal to or greater than the entire size of your site once compressed.
* wp-config.php file must be in WordPress installation directory OR (starting with v3.0) in the parent directory.
+
* wp-config.php file must be in WordPress installation directory OR (starting with BackupBuddy v3.0) in the parent directory.
  
 
===Host Compatibility===
 
===Host Compatibility===
Line 84: Line 75:
  
 
===Frequently Seen Support Issues===
 
===Frequently Seen Support Issues===
''Problems?'' Start with the [[BackupBuddy:_Frequent_Support_Issues|Frequently Seen Support Issues]] to most quickly troubleshoot your problem.
+
''Problems?'' We have compiled a list of issues and solutions to many problems that we have seen encountered before. [[BackupBuddy:_Frequent_Support_Issues|Frequently Seen Support Issues]] to attempt to narrow down your problem and find a solution.
 
+
  
 
===BackupBuddy: Error Codes===
 
===BackupBuddy: Error Codes===
Line 101: Line 91:
 
* [http://ithemes.com/codex/page/File:Zip_test.zip Manually test command line zip functionality]
 
* [http://ithemes.com/codex/page/File:Zip_test.zip Manually test command line zip functionality]
  
 +
=Multisite=
 +
 +
BackupBuddy supports the following Multisite functionality:
 +
* Export a Multisite subsite to standalone
 +
* Import an exported Multisite subsite into an existing Network
 +
* Import a standalone WordPress site into an existing Network
 +
* Backup entire Network (backup/restore only; no migration to new URL)
 +
* Restore entire Network WITHOUT URL migration for subsites within if migrating to a new URL (URL changes have limitations. Please see Multisite page for details)
 +
 +
 +
[http://ithemes.com/codex/page/BackupBuddy_Multisite Check out the BackupBuddy Multisite Codex] and [http://pluginbuddy.com/purchase/backupbuddy/ Get BackupBuddy Multisite Beta Today!]
 +
 +
BETA indicates that Multisite functionality has known issues and is not reccomended for production use except at your own risk.  We do NOT guarantee its functionality or provide guaranteed support for beta products.
  
 
'''Links'''
 
'''Links'''

Revision as of 16:38, December 29, 2012

Contents

Tutorials

Installing BackupBuddy

Check out the Installing BackupBuddy section to see how BackupBuddy can be uploaded and activated on Single sites or Multisite networks or Multisite sites.

Getting Started

Check out the Getting Started page to backup your Single sites or Multisite networks.


Restore or Migrate

Learn to Restore or Migrate your Single sites or Multisite networks with the latest importbuddy.php.


Settings Explained

Get in depth information about the various Settings.


Developing Locally

Set up your computer to Develop Sites Locally and then migrate them to your live site.

Specifications

Server configuration is a very complex topic and varies wildly between hosts, server operating systems, and even the personal preference of the server administrator. Below are the bare minimum requirements for the plugin along with the recommended setup to get the most out of this plugin. You may use ServerBuddy to help you determine how your server compares to our minimum requirements & recommendations.

Server Recommendations (full functionality)

  • PHP 5.2+
  • mySQL 5.x+
  • WordPress 3.3+
  • Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
    • Backups will be stored in /wp-content/uploads/backupbuddy_backups/
    • Temporary files will be stored in /wp-content/uploads/backupbuddy_temp/xxxxxxx/ (temporarily generated at each backup)
  • Free disk space equal to or greater than the entire size of your site once compressed.
    • SuPHP or environment so that file operations/zip run as user to prevent permissions issues.
    • PHP exec() function enabled
    • PHP ZipArchive class installed
  • Linux (Apache):
    • Command-line zip installed and accessible via exec().
  • Windows (only supported for local development via Apache; IIS is not officially supported):
    • Windows zip executable (available here)
      • You must have the ability to configure your server to allow execution of this zip.exe file for it to function.
      • File permissions must also be set to allow access and execution of the zip executable.
  • wp-config.php file must be in WordPress installation directory OR (starting with BackupBuddy v3.0) in the parent directory.

Minimum Server Requirements (reduced functionality)

NOTE: Some features of BackupBuddy will be unavailable or limited if running on minimum requirements without recommendations. Large sites may not be able to be backed up with these minimum features.'

  • PHP 5.2+
  • mySQL 5.x+
  • WordPress 3.2+
    • We are trying to maintain bare minimum backup functionality for legacy versions as far back as WordPress v2.6 (though it's not pretty nor guaranteed to work perfectly at this time; we recommend only performing backups & direct restores for older versions and use it for safety while upgrading to the latest WordPress).
  • Write permissions to /wp-content/uploads/ for the user running BackupBuddy.
  • BackupBuddy requires the uploads directory to be in the standard WordPress location.
    • Backups will be stored in /wp-content/uploads/backupbuddy_backups/
    • Temporary files will be stored in /wp-content/uploads/backupbuddy_temp/xxxxxxx/ (temporarily generated at each backup)
  • Free disk space equal to or greater than the entire size of your site once compressed.
  • wp-config.php file must be in WordPress installation directory OR (starting with BackupBuddy v3.0) in the parent directory.

Host Compatibility

Compare various Hosts & Hosting Environments to see how your host/potential host compares.


Misc. Information

Find out some Miscellaneous Information about BackupBuddy.


Troubleshooting

Frequently Seen Support Issues

Problems? We have compiled a list of issues and solutions to many problems that we have seen encountered before. Frequently Seen Support Issues to attempt to narrow down your problem and find a solution.

BackupBuddy: Error Codes

Receive an error code? Check out the Error Codes page for explanations.


Manual Migration

Import fails on file extraction? Learn how to perform a Manual Migration ... it's easier than you'd think!


Additional Resources

Tools

Multisite

BackupBuddy supports the following Multisite functionality:

  • Export a Multisite subsite to standalone
  • Import an exported Multisite subsite into an existing Network
  • Import a standalone WordPress site into an existing Network
  • Backup entire Network (backup/restore only; no migration to new URL)
  • Restore entire Network WITHOUT URL migration for subsites within if migrating to a new URL (URL changes have limitations. Please see Multisite page for details)


Check out the BackupBuddy Multisite Codex and Get BackupBuddy Multisite Beta Today!

BETA indicates that Multisite functionality has known issues and is not reccomended for production use except at your own risk. We do NOT guarantee its functionality or provide guaranteed support for beta products.

Links

  1. Purchase BackupBuddy
  2. BackupBuddy Multisite Codex
  3. BackupBuddy beta Multisite support announcement
  4. BackupBuddy beta Multisite key points everyone is raving about!
  5. PluginBuddy Tutorials
  6. PluginBuddy.com
  7. Support Forums
Personal tools
Namespaces
Variants
Actions
iThemes Codex
Codex Navigation
Toolbox