Builder Known Issues

(Difference between revisions)
Jump to: navigation, search
(Created page with "== Error message /modules/class.module.php:153:Call-time pass-by-reference has been removed == ===The cause=== This error message shows because your server is (now) running PH...")
 
(Update Builder)
Line 6: Line 6:
 
Builder theme, and Builder plugins (Builder Stylemanager and Builder SEO) need to be updated to the latest version to be compatible with PHP 5.4.
 
Builder theme, and Builder plugins (Builder Stylemanager and Builder SEO) need to be updated to the latest version to be compatible with PHP 5.4.
  
If you have a current subscription, you can download Builder, Builder Stylemanager and Builder SEO from [http://ithemes.com/member/panel/downloads.php|your membership page]. Unzip these files to a known location on your computer. Then, you can [http://codex.wordpress.org/Using_Themes#Adding_New_Themes_Manually_.28FTP.29|manually upload the (unzipped) theme files] to the <code>wp-content/themes/</code> (or the plugin files to the <code>wp-content/plugins/</code>) folder using FTP or your hosting cPanel. You should Rename the existing theme or plugin folders on your server first.
+
If you have a current subscription, you can download Builder, Builder Stylemanager and Builder SEO from your [http://ithemes.com/member/panel/downloads.php|your membership page]. Unzip these files to a known location on your computer. Then, you can [http://codex.wordpress.org/Using_Themes#Adding_New_Themes_Manually_.28FTP.29|manually upload the (unzipped) theme files] to the <code>wp-content/themes/</code> (or the plugin files to the <code>wp-content/plugins/</code>) folder using FTP or your hosting cPanel. You should Rename the existing theme or plugin folders on your server first.
  
 
====Update existing code====
 
====Update existing code====

Revision as of 06:16, December 17, 2013

Contents

Error message /modules/class.module.php:153:Call-time pass-by-reference has been removed

The cause

This error message shows because your server is (now) running PHP 5.4 and an outdated version of Builder theme, or the Builder plugins (Builder Stylemanager and Builder SEO) is active on your site.

The solution

Update Builder

Builder theme, and Builder plugins (Builder Stylemanager and Builder SEO) need to be updated to the latest version to be compatible with PHP 5.4.

If you have a current subscription, you can download Builder, Builder Stylemanager and Builder SEO from your membership page. Unzip these files to a known location on your computer. Then, you can upload the (unzipped) theme files to the wp-content/themes/ (or the plugin files to the wp-content/plugins/) folder using FTP or your hosting cPanel. You should Rename the existing theme or plugin folders on your server first.

Update existing code

Replace all instances of &$ with $ in all the Builder theme and Builder plugin (Builder Stylemanager and Builder SEO) php files. Make a backup of the theme and plugin files before you do.

If that doesn't resolve this, and you have a current subscription, for further assistance, please post a support request in the Builder support forum: http://ithemes.com/forum/forum/64-builder/

See also


← Back to Builder Codex Home

Personal tools
Namespaces
Variants
Actions
iThemes Codex
Codex Navigation
Toolbox