General Plugins FAQ

From IThemes Codex
(Difference between revisions)
Jump to: navigation, search
(Added - Unable to use special characters in Widget titles OR Widget Title shows forward slash \: sub-section)
(Clarified the older versions info a bit more, and added Related Threads. - Downloading OLDER Versions)
 
Line 54: Line 54:
 
=Downloading OLDER Versions=
 
=Downloading OLDER Versions=
  
If you want ANY older version of ANY plugin, please go ahead and [http://ithemes.com/forum/ post on our forums please] in the appropriate category with your request and a reason why you want the older version. We will do our best to accommodate such a request (though we can't guarantee it, since we officially support only the latest version of each plugin), and your reasoning helps us figure out whether we should give you an alternate/latest version, a workaround, or if should suggest something else.
+
If you want ANY older version of ANY plugin, please go ahead and [http://ithemes.com/forum/ post on our forums please] in the appropriate category with your request and a reason why you want the older version. We will do our best to accommodate such a request (though we can't guarantee it, since we officially support only the latest version of each plugin), and your reasoning helps us figure out whether we should give you an alternate/latest version, a workaround, or if we should suggest something else.
 +
 
 +
Sometimes, a version of a plugin may not show up in the [http://ithemes.com/member/member.php iThemes Member's area]. In that case, please post in the appropriate category to let us know about it and we will get the right version link up and running as soon as possible.
 +
 
 +
Regardless of your reasoning, we will offer you something that will do what you want to do if it's a stable feature in one of our previous OR existing stable versions for your exact setup.
 +
 
 +
Remember, though: support is guaranteed only for the latest, officially supported stable versions of our plugins.
 +
 
 +
*Related threads
 +
**http://ithemes.com/forum/index.php?/topic/18916-fatal-error-call-to-undefined-function-is-multisite/#p93019
 +
**http://ithemes.com/forum/index.php?/topic/18448-download-legacy-versions-of-backupbuddy/#p86712

Latest revision as of 14:24, October 31, 2011

Contents

Plugin Display Issue

My Plugin Won't Show Up! I'm using more than one jQuery on my site

When more than one jQuery is used on the same site or the same page/post, sometimes older jQuery versions or incompatibilities can cause any plugin, including PluginBuddy plugins, from appearing on your live site.

  • There are several ways to check if this may be the cause of the problem. Here is the most effective method:
    • Check the source code of the page where the problem is happening. jQuery usually (or always) shows its version number in any place where it is called. Make sure that number is consistent or at least among the latest versions in all such urls/calls.
  • There are several ways to get this fixed:
    • Try to use only a single jQuery throughout the whole site.
    • Update all jQuery related plugins, OR any plugins using jQuery, to the latest versions.
    • Ensure that your theme is not calling an older, incompatible or modified version of jQuery that may be interfering with your PluginBuddy plugins. If your theme is calling a jQuery, ensure that it is the latest version. Contact your theme developer to see if you can get the latest jQuery added to your theme while keeping any customization you made to the theme intact.

Remove Bullets in OLDER IE Browsers

  • In many older IE versions, including when viewing in the new IE Compatibility Mode, you may notice bullets, images, arrows or similar things before each UL or LI (list). This can happen in many plugins, including the ContactBuddy plugin.
  • THIS IS A KNOWN OLD-IE-VERSIONS ISSUE ACKNOWLEDGED BY MICROSOFT.
  • The "fix" for this is as follows:
    • Add the following code to your theme's css file at the very end:
ul li
{
list-style-image:none !important;
list-style: none !important;
list-style-type: none !important;
}

Unable to use special characters in Widget titles OR Widget Title shows forward slash \

Sometimes, you may have trouble inserting characters in Widget titles, OR the Widget titles may show a forward slash \ before such special characters.

For example, the widget title Cartoon's turns into Cartoon\'s

This can happen in many plugins, including some PluginBuddy plugins. The reasons can vary from the plugin version being outdated on a specific install to being a bug in the plugin (if you find any, let us know! :) ).

There is a workaround. When using any special character that is causing such issues, use the HTML code for it instead.

For example, Cartoon's can be written as

Cartoon& # 3 9 ;s
(remove the spaces)

the & # 3 9 ; (remove the spaces) code shows the apostrophe' character. The above will then show the Cartoon's word properly.

Downloading OLDER Versions

If you want ANY older version of ANY plugin, please go ahead and post on our forums please in the appropriate category with your request and a reason why you want the older version. We will do our best to accommodate such a request (though we can't guarantee it, since we officially support only the latest version of each plugin), and your reasoning helps us figure out whether we should give you an alternate/latest version, a workaround, or if we should suggest something else.

Sometimes, a version of a plugin may not show up in the iThemes Member's area. In that case, please post in the appropriate category to let us know about it and we will get the right version link up and running as soon as possible.

Regardless of your reasoning, we will offer you something that will do what you want to do if it's a stable feature in one of our previous OR existing stable versions for your exact setup.

Remember, though: support is guaranteed only for the latest, officially supported stable versions of our plugins.

Personal tools
Namespaces
Variants
Actions
iThemes Codex
Codex Navigation
Toolbox