Jump to content


Replying to Exchange Performance


Post Options

  or Cancel


Topic Summary

echoleaf

Posted 20 March 2014 - 05:02 AM

.1368 - quite an improvement.  The increase in overall load time is strange as I haven't made any other changes to the site.

Elise Alley

Posted 19 March 2014 - 12:00 PM

Hi echoleaf,

You said previously, "Exchange alone is taking .5744 seconds to load."  How fast is Exchange loading now?

Thanks,

Elise

echoleaf

Posted 19 March 2014 - 10:44 AM

Now my total page load time went UP to 7.0714. However when I load the site is seems a bit faster.

Elise Alley

Posted 19 March 2014 - 09:40 AM

Hey echoleaf,

We've just released an update of Exchange (version 1.7.19) that helps address this issue.  Try updating and see if that helps speed things up.

Let us know how it goes.

Thanks,

Elise

Posted 18 March 2014 - 10:28 AM

It did not note it but I just tried adding the function to remove Stripe from unnecessary pages and the performance scan was roughly the same - except this time it showed each iThemes plugin individually.  Exchange went down .4753 and total page load time went from 5.6960 to 4.8434.  So definitely some improvement, but not a ton.

Posted 18 March 2014 - 10:15 AM

It didn't state that specifically - it just labeled it 'Exchange'.  I'll check that thread out and see if it helps.

Rob Hess

Posted 18 March 2014 - 10:11 AM

View Postecholeaf, on 18 March 2014 - 06:52 AM, said:

stripe: 1.1.23

Hi echoleaf,

Out of curiosity...when you ran P3 did it group the stripe.js/checkout.js in with the Exchange stuff? I've found that checkout.js loads on every page and adds about 500ms by itself. You can follow the instructions in this thread to strip it out on most pages.

echoleaf

Posted 18 March 2014 - 06:52 AM

URL
www.sunriseprowebsites.com

Versions
exchange: 1.7.18
invoices: 1.04
recurring payments: 1.0.17
stripe: 1.1.23
wp: 3.8.1

Elise Alley

Posted 17 March 2014 - 02:54 PM

Hi echoleaf,

Can you give us some more information?  What's your URL?  What version of Stripe are you using?  The version of the other plugins?  What version of WordPress are you using?  That sort of thing.

Any additional information you can give us would be helpful!

Thanks,

Elise

echoleaf

Posted 17 March 2014 - 06:42 AM

I just ran the P3 - Plugin Performance Profiler on my site and Exchange alone is taking .5744 seconds to load.  The next highest items are Wordpress Core (.0973s) and WordPress SEO (.0935s).  I'm using Exchange, Invoices, Recurring Payments & Stripe.  Is this the kind of performance that should be expected?  

Review the complete topic (launches new window)