Jump to content


Replying to Using Stripe, Getting 404.


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 31 July 2013 - 01:22 PM

Hey Cash,

I just wanted to let you know that we haven't been able to reproduce this issue that you're having.  However, we did just release an update for Exchange, version 1.1.0.  Would you mind testing with this new version and let us know whether or not the error continues to occur?

Give that a try and let us know how it goes!

Thanks,

Elise

Elise Alley

Posted 23 July 2013 - 10:14 AM

Hey Cash,

Can you copy the exact error message you got when you reactivated WishList so that I can pass it along to the developers?  They'll look into the issue, but I don't have a timeline for how long it will take to correct unfortunately.  But if you can get me the error message, they'll take a look!

Thanks,

Elise

cash60

Posted 23 July 2013 - 08:05 AM

Hey Elise,

After giving it some thought, it seems that WishList is going to be critical for our business. Kind of at a jam over what to do now.

Thanks,
Cash

Elise Alley

Posted 22 July 2013 - 02:06 PM

cash60,

Just a reminder before you start making changes like this, we always recommend you make a backup of your site.  That way, if you run into any issues, you can always restore from where you started!

Let us know if you have any questions!

Thanks,

Elise

Elise Alley

Posted 22 July 2013 - 01:49 PM

Hey cash60,

If you're not using or don't need WishList, can you try fully deleting it from your site?  You may need to even go into your database and make sure it's cleared out of there too.  Once you've done that, try testing Stripe in Exchange again and then see if that clears up the issue.

Thanks,

Elise

cash60

Posted 22 July 2013 - 10:27 AM

Elise,

I wish I could be more helpful. We never integrated WishList with Stripe, we were using PremiumWebCart and Authorize Net as our gateway. But when we got our merchant account finally approved by Bank Of America (ughh), they wanted us to use their gateway, which wasn't listed as one of PremiumWebCart's pre-set gateways.

Then we saw Exchange from iThemes and Stripe and it seems like a home run. Not even sure if WishList is needed anymore, tbh.

Let me know if I can help in any way.

Elise Alley

Posted 22 July 2013 - 10:11 AM

Hey cash60,

That could definitely be the issue!  When using WishList Member, if someone makes a purchase with Stripe, does it send them to the /transaction page?  

I'm going to bump this up so that the developers are aware of the issue and can take a look at it.  I'll get back with you when I have answers from them.

Thanks,

Elise

cash60

Posted 22 July 2013 - 09:57 AM

For what its worth,

I had all plugins deactivated except Exchange and Stripe Add on. I when I went about activating my other plugins, I received a fatal error when trying to activate WishList Member.

Seems the error is because both plugins are trying to use the class Stripe ().

cash60

Posted 22 July 2013 - 09:47 AM

Hi Elise,

These settings should still be the defaults....

Thanks,
Cash

Elise Alley

Posted 22 July 2013 - 09:41 AM

Hey cash60,

When you make a purchase, it should take the user to the page /confirmation/(confirmation #), not to /transaction.  Can you provide us with a screenshot of your Exchange > Settings > Pages page?  That may help us narrow down the issue you're having.

Thanks,

Elise

Review the complete topic (launches new window)