Jump to content


Replying to Page Not Found When Viewing A Product?


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 25 September 2013 - 09:12 AM

Hey Carol,

I understand and I know that takes some time.  Just let us know when you're done testing and an issues that you've found.  

If you'd like, you can send me login information for your site and I can go ahead and take a look.  You can PM me the login information here on the forum or email it to me at elise@ithemes.com.  Just be sure to include a link to this post so I know what your message is in regards to.

Thanks,

Elise

Carol Cody

Posted 24 September 2013 - 10:44 PM

Elise,

The product slug is wpguide.

The store is set to http://carolcody.com/store/ but the page goes to the blog. In fact, all the dynamic exchange pages go to the blog or a page not found error :(

I've test for the plugin conflict but got a lot of plugins so it is going to take a little time. Will get back to you in a few days.

Thanks,
Carol

Elise Alley

Posted 24 September 2013 - 03:23 PM

Hey Carol,

When you go into the product, in the Advanced Options, what is the Product Slug set to?  Can you also provide us with a store page or the url for the "All Products" page?  I tried /store, didn't see that product there.

Can you also test to see if there is a plugin conflict?  So deactivate all of your plugins except for Exchange and then see if it links to the correct page.  If it does, reactivate your other plugins, one at a time, testing Exchange each time, to see which plugin is creating the conflict.

Give that a try and then let us know how it goes.

Thanks,

Elise

Carol Cody

Posted 23 September 2013 - 11:56 PM

Ronald,

Tried refreshing the .htaccess file like you suggested, but no luck. Still had the problem with the first downloadable product so I created a new one. No problem switching from the edit screen to viewing the product for a couple of times, but eventually I was redirected to a "page not found" and now am unable to view the product.

Any more ideas?

Thanks,
Carol

Ronald

Posted 23 September 2013 - 06:49 AM

Hi Carol,

can you try tregenerating the htaccess file? To do so, go to wp-dashboard > Settings > Permalinks, scroll down and click "save changes". No need to actually change anything though, but it should refresh the htaccess file used by your site,

Ronald

Carol Cody

Posted 21 September 2013 - 02:09 AM

Hi,

I'm troubleshooting one of my products not appearing.

When I hover over the view link in the All Products page it reads:
http://carolcody.com/product/wordpress-guide/

But when I click on this link, I'm redirected to:
http://carolcody.com/it_exchange_download/wpguide/
a page not found :(

What am I missing?

Thank you for your assistance!
Carol

Review the complete topic (launches new window)