Jump to content


Replying to Builder Views Issue With Exchange


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 05 March 2014 - 02:07 PM

Hi Julie,

I'm not quite sure I understand - are you using Exchange now?  Or are you still using Woocommerce?  

This particular forum is for Exchange.  If you're not using Exchange and are needing help with Builder, you'll want to log in and post your question in the Builder forum.  

If you're still using Woocommerce, you may want to ask your question to their support team.

Thanks,

Elise

Posted 02 March 2014 - 02:07 PM

I am having a similar issue but I used woocommerce.  At the time I started this site, I don't believe exchange was an option, and I have made several revisions to the site since then, but she has many sales in the woocommerce.

She wants the shopping cart to show on the product pages, but the blog should show the archives and categories.

Any help is appreciated.

http://coloradoaromatics.com

Thanks,

Julie

David Weuste

Posted 21 October 2013 - 05:35 PM

Well, since the only solution seems to be assigning 14 views, I've just gotten rid of using an extension for the blog and just creating a loopbuddy layout to do the same thing. Then the views don't matter and Exchange works just fine.

David Weuste

Posted 18 October 2013 - 01:39 PM

I suppose if there is a way to separate the Exchange default view from the Blog Posts View? It seems odd that I can't isolate it one from the other besides assigning specific Exchange views.

Ronald

Posted 18 October 2013 - 01:23 PM

Hi,

I created a layout and added a view (for the "Account" page) from the backend of your site to see if assigning a view works properly. And it does. And unfortunately, adding 14 views is the only way to get this resolved until (and if) the feature request has been honoured. So what exactly are you expecting Elise to figure out further?

Ronald

David Weuste

Posted 18 October 2013 - 01:11 PM

Hi Ronald, thanks for adding that feature request, adding 14 views is a bit cumbersome. I'll wait and see if Elise is able to figure something out when she logs into the admin area.

Ronald

Posted 18 October 2013 - 12:58 PM

Hi,

currently, there is currently no to assign a view to "All Exchange Pages". Having said that, there are 14 Exchange pages, and you can set each through the "Views" function in Builder. I just did by adding a test layout ("Exchange") and applied that to the "Exchange - Account" page: http://sites.rosebrookmedia.com/buildmyaudience/account/ As you can see, that works fine. So for now, you need to assign a View to each page, and you have the option(!) to assign a specific layout to each Exchange page.

I will put in a feature request to enable assigning views to all 14 layouts in one go though,

Ronald

David Weuste

Posted 17 October 2013 - 04:07 PM

Hi Ron, thanks for joining here. The issue is that the Exchange ghost-pages (there aren't any products in the store yet, but the focus for this site is the new membership option, so having pages like /account and /account/memberships work correctly is imperative) are all copying the "Blog" view that I have set in the Views. Since there is an extension set there, it completely messes up the Exchange pages. I really don't want to have to set every single one of those Exchange pages in the Views settings, I really wish there was a "All Exchange Pages" view because all of the exchange pages are messed up by the extension assigned to the blog.

Ronald

Posted 17 October 2013 - 03:48 PM

Hi,

I am having a look from the Builder perspective, but I don't understand what exactly the issue is. Which page is not looking right? And I don't see any active Exchange products, is that intentional?

To assign a layout to an Exchange page, you should also use the Builder Views. Is that not working for you?

Posted Image

Also, make sure that a layout that you are using is not using LoopBuddy as well,
Ronald

David Weuste

Posted 17 October 2013 - 11:11 AM

Email Sent.

Review the complete topic (launches new window)