Jump to content


Replying to Exchange - Simple Paypal Payment - Not Working Correctly


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 06 January 2014 - 04:25 PM

Hi Jamie,

Can you please start a new thread?  If you've followed the steps provided by Glenn and are still having issues, it is possibly a separate issue.  

In your new thread, please give as much detail as possible.  For instance, you said it seems to work fine on "gratis sales."  Does it work when they select a price?  Or just when they set their own price?  Are the customers registering on your site?  Or are you using guest checkout?  Any additional information would be helpful.  And be sure to again include a link to your site.  

Thanks,

Elise

jamierowe

Posted 06 January 2014 - 01:58 PM

Got a sale a moment ago. The same issue. I was able to get their email from my paypal notification and was able to send them the product directly.
Went into dashboard. Shows them as "deleted customer". Since this is member support, I'm hoping y'all can help me pretty quickly. Otherwise I'm gonna; have to shut down my store for awhile til it gets sorted.
Thanks!
jamie

Screenshot
http://www.webpagescreenshot.info/img/52cb0a5f017a93-34753713

jamierowe

Posted 05 January 2014 - 04:23 PM


Glenn Ansley

Posted 31 December 2013 - 11:30 AM

Hi everyone,

If you're using PayPal Standard and getting this error, you probably haven't setup IPN for your PayPal account. Please Log into your PayPay, go to Profile --> My Selling Tools --> Instant Payment Notifications (this is different than managing API Access) and make sure you have IPN enabled. Without IPN enabled, PayPal has no way to communicate back to Exchange and tell us that the payment went through.

Additionally, you will see that PayPal asks for a default URL in the IPN. Exchange does not use the default. We send the correct address via PayPal's IPN API.

flowta

Posted 12 December 2013 - 11:42 PM

Hi All
Im just commissioning a site using standard paypal, and I have this error also Unknown error while processing with PayPal. Please try again later.

The following also happened:
. the return to the site process didnt work, and an insecure form message page appeared
. when I returned to the page, the above error message against the transaction was showing
. the item was still in the shopping cart
. the paypal transaction appears to have gone thru OK (I got the PayPal receipt)
. the payment transaction in Exchange shows the user as "Deleted User", and there is no email address, so contacting the user would be problematic. But the transaction record shows Paid with Billing and Shipping Address showing.

The site is dmjbooks.com

I have just updated the site to WP3.8. and the very latest Exchange. Site is in my Sync account.

I can provide access on request.

I think it essential that all emails of clients be maintained in the transaction record, and be available to the site admin.

jamierowe

Posted 29 November 2013 - 09:29 PM

Hey folks,

Was there ever a solution here? I'm testing exchange tonight and getting the same error doing a digital download.
  • Unknown error while processing with PayPal. Please try again later.
Edited to add: The payment is going through on the paypal side. I'm getting confirmation email from them and even a confirmation email internally with the "yabba dabba doo" message. 3 sales all the same, but when it sends me back to page, it shows the item in the cart with the Unknown error while processing with PayPal. Please try again later. message. And the internal dashboard says Purchases "0"

patdumond

Posted 22 November 2013 - 12:02 PM

I had someone else try a purchase on the site. They got the same result I got -- sale goes through, error message on return to site, item remains in cart. It isn't my account.

patdumond

Posted 22 November 2013 - 09:42 AM

Just for chuckles, I decided to troubleshoot my quasi-theory that I had different emails on PayPal and TBE (Treasures by Eleni) was causing this problem. It isn't. I checked out as a guest using my PayPal email address and got the same error and the item I purchased remained in my shopping cart. I know you said you didn't the get the error during your test last night, but I'm getting it 3 different ways of checking out - 1) as a logged in customer, 2) from the same PayPal account and email as a guest, 3) for a different email/same PayPal account as a guest. It happens every time I checkout. I've purchased different items. I've purchased different number of items.

I suppose it could be a problem with my PayPal account, but my credit card bills will show I can successfully use that account all over the internet without this problem. I've asked the site owner to get someone else to test it, but she's on the West Coast and often not available until late afternoon her time.

patdumond

Posted 21 November 2013 - 02:41 PM

View PostElise Alley, on 21 November 2013 - 12:58 PM, said:

Hi patdumond,

Can you send me admin login credentials for your site so I can take a look at the backend?  You can email them to me at elise@ithemes.com or PM them to me here on the forum.  Just be sure to include a link to this post so I know what the message is in regards to.

Thanks,

Elise

Done.

Elise Alley

Posted 21 November 2013 - 12:58 PM

Hi patdumond,

Can you send me admin login credentials for your site so I can take a look at the backend?  You can email them to me at elise@ithemes.com or PM them to me here on the forum.  Just be sure to include a link to this post so I know what the message is in regards to.

Thanks,

Elise

Review the complete topic (launches new window)