Jump to content


Replying to Product Image Issue; And General Styling Question


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 14 January 2014 - 05:47 PM

Hi Christine,

The issue could be related to a theme conflict or a plugin conflict.  There aren't any known conflicts with this (it's actually the first time I've had this reported).  I'd start by testing for a theme conflict by temporarily activating one of the WordPress default themes like Twenty Fourteen.  If that doesn't correct the issue, then try testing for a plugin conflict by deactivating all of your plugins except for Exchange and see if it works properly.  If it does, reactivate your other plugins one at a time, testing Exchange each time, to see which plugin is creating the conflict.

The bullets (you mentioned in the video) you are seeing next to the product images are coming from your theme.

There isn't necessarily an ideal size that we list for product images.  For the your featured images that will display on the store page, we recommend that they are the same size, just to keep things a little more uniform.  You can target the images on the store page using the class .it-exchange-featured-image in your CSS if you want to edit them.  A large image, according to WordPress, is 1024 x 1024.  You don't need them to be that large necessarily, but, as you said, the larger images allow for zoom.  

I'm not sure what you mean by "product boxes."  Are you talking just about how the products display on the store page?  If so, you can target the products using the class .it-exchange-product.  What you'll want to do is create a directory name exchange in your theme and then upload a file name style.css with any of your custom styles.  

Let me know how the conflict testing goes.

Thanks,

Elise

Christine--FLPedaler

Posted 14 January 2014 - 02:00 PM

II chose a WP page to be the store page...
I added 4 test products.. .and they ARE showing up on the preferred page of choice.  

The issue I have is that that if you are on product page and click on any extra images there, they don't move or enlarge or do anything.  This is not my site, and not an ithemes site, so this is either an Exchange bug, or a settings error, or a plug in conflict...?  Where should I start?   Do you know of any KNOWN conflicts that would cause this?

The site is behind a "coming soon" page, so I can't give you a url to see... but here is a jing video to show what is happening... (or not happening)...
http://screencast.com/t/6U3QMfbz

And FYI, the settings I have for images on the settings page are:  
   enable pop up-YES and
   enable zoom-YES  

But, the settings for images for either click or hover don't do anything.  (tried both hover and click, but neither worked).
I saw the note about it needing a large image for zoom... but, do you know "how" large is considered large?  
Regardless, the pop up should work, right - or if you click on an alternate image, it should either pop up, go into the  main image box or something like that?  

What is the ideal image size for a product? ... would it prefer to not overwhelm the product box on the store page..
.
Which brings me to a related question - and has to do with styling Exchange... is there a way to change size and/or margins or paddings between product boxes, or a way to make them not so "in your face"?  Maybe even add dividers or background colors so they don't seem so close together?

Thanks for your help.
Christine

Review the complete topic (launches new window)