Jump to content


Replying to Registration Page Error Notifications


Post Options

  or Cancel


Topic Summary

Rob Hess

Posted 18 March 2014 - 10:07 AM

View PostTroy, on 24 January 2014 - 10:03 PM, said:

It wasn't that difficult to do once I figured out the proper way to add fields to Exchange forms.

Hi Troy, would you be able to share how you went about adding this field to the Exchange forms? I need to do the same thing, and thought I might save some time by finding someone who has blazed that trail already. :)

Thanks!
Rob

Posted 24 January 2014 - 10:03 PM

Thanks for the reply. The no data being return is a bummer, I hope it gets fixed soon :-)

In regards to the password strength requirement, as far as I can tell it's been part of the WordPress core since 3.7. I couldn't find a plugin that was causing it. Long story short, I ended up adding the WordPress built-in strength meter to the registration page. Now the users can at least tell their password strength before submitting the form. I also put a hint next to the indicator that the password MUST be strong in order to register successfully. It wasn't that difficult to do once I figured out the proper way to add fields to Exchange forms. You guys should think about adding it to the form by default.

Thanks,
Troy

Elise Alley

Posted 24 January 2014 - 06:04 PM

Hey Troy,

Unfortunately, the form currently doesn't retain information in case of an error, so this isn't happening just on your site.  I have added it as a feature request though on the Exchange Roadmap.  

Exchange doesn't actually have a strength requirement for passwords, which is why there isn't a password strength indicator.  So, you might check to see if you have another plugin that's requiring a strong password.  You can try deactivating all of your plugins and then see if it still requires a strong password to register.  If it doesn't, reactivate your other plugins one at a time and test each time to determine which plugin is causing this issue.  

Let us know if you have any other questions.

Thanks,

Elise

Posted 24 January 2014 - 02:37 PM

When using the Exchange registration form, if the user encounters an error (username already in use, required filed missing, password not strong enough, etc...), the page is re-displayed with the error notification at the top of the page. However, the form has lost all the data the user entered and they are forced to enter everything again. This is VERY frustrating, especially when trying to get your password strong enough. Can this be fixed or is this just happening in my installation?

Second, I would like to see a password strength indicator used so that the user can see if it's acceptable before trying to submit the registration form. These two things would greatly increase the user friendliness of the registration form. As of right now, it's very frustrating for my potential customers.

Thanks
Troy

Review the complete topic (launches new window)