Jump to content


Replying to Product Images On Category Page Not Working


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 11 February 2014 - 05:30 PM

Happy to have helped, trundlemedia.  Let us know if you have any additional questions.

Thanks,

Elise

trundlemedia

Posted 11 February 2014 - 04:44 PM

Perfect, it worked!  Thanks so much!

Elise Alley

Posted 11 February 2014 - 04:06 PM

Hi trundlemedia,

You won't have to wait that long.  I actually have an answer for you now!  :)  

Either in your archive.php or category.php file (which ever one your theme calls, for instance Twenty Eleven calls archive.php), enter the following code right after your loop starts:

<?php it_exchange_set_product( $post->ID ); ?>

Then, where you want the image to show, enter this code:

<?php it_exchange( 'product', 'featured-image', array( 'size' => 'thumbnail' ) ); ?>

So it'll look something like this:

ArchiveExchangeFeaturedImages.png

I'll get this added to the codex soon, but if you want to go ahead and test it out, let us know how it goes!

Thanks,

Elise

trundlemedia

Posted 11 February 2014 - 03:06 PM

Hi Elise, thanks for getting back to me so quickly!

Do you have a timeframe for this? At this point I'm kinda stuck with development on my client's site and I can't just put it off indefinitely.

If it's within a week or so I should be ok.. but any longer than that will start causing problems :/

Elise Alley

Posted 11 February 2014 - 02:55 PM

Hi trundlemedia,

Exchange doesn't use the regular WordPress featured image, so calling it in as you've listed above will not call in the Exchange product's featured image.

This is possible, however, with the theme API.  We're working on a tutorial now and should have more information on how to do this soon.  I just didn't want you to think we were ignoring your post in the meantime!  :)

I'll post here again as soon as we have the information available.

Thanks,

Elise

trundlemedia

Posted 11 February 2014 - 02:16 PM

I have a store setup with a custom theme I am building.

I have 2 main categories of products... so my products are appearing on the following pages:

   /product-category/jewelry/
   /product-category/decor/

These pages apparently use archive.php to display the items.

I have added theme support for the featured images:

functions.php:
// Add featured image support
add_theme_support( 'post-thumbnails' );

archive.php:
$post_id = get_the_ID();
the_post_thumbnail($post_id);


My blog posts are successfully showing the featured image, so I know featured images are correctly enabled.. but my products on the products page do not.

I need to know how to get this working ASAP or I need to find a different shopping cart plugin.. Getting this to work is absolutely necessary.

Thanks

Review the complete topic (launches new window)