Jump to content

Replying to Missing 5 Groups And 50 Plus Products

Post Options

  or Cancel

Topic Summary


Posted 13 March 2014 - 08:31 PM

I will add that I also have the same issue as plutonic in that I have tried unsuccessfully on a number of ocassions to drag a group with a number of restriction rules to reposition them and it does not allow me to drop them anywhere. I was trying to get everything in alpha order but finally gave up. It appears the only way is to put them in alpha order when you create your membership groups. To the issue of groups mysteriously disappearing, I finally went back and manually repopulated all 50-plus products. To be safe, I cloned that membership immediately and hope that if one gets messed up, I'll be able to bring back the other.


Posted 13 March 2014 - 12:25 PM

Thanks Elise, no worries. Right now I've got everything structure, so will leave as-is.


Elise Alley

Posted 11 March 2014 - 03:53 PM

Hey Tim,

I just wanted to let you know I didn't miss your post.  I'm trying to recreate it myself and will also be discussing it with the developers.  So it might take me a little time to get back with you.  I just wanted to keep you in the loop.




Posted 08 March 2014 - 03:33 PM

Hi Elise,

We just have one Membership product right now, and no other products or product types.

We have the following Add-ons enabled in Exchange:
Basic Reporting Dashboard Widget
Digital Downloads
Manual Purchases
Membership for bbPress
WordPress Page Templates
Recurring Payments
Simple Products
Switch Product Types
Product Categories
Product Tags

I did not add the groups/restrictions in order when originally creating the product since it's the only product we have right now (we just added and moved groups and restrictions after the initial product creation).

The sequence went like this:
  • I first created a Membership product.
  • Later, I created groups for content access.
  • Then I created subgroups for the initial groups (no more than two deep: main group>sub-group1).
  • Then I created the restriction rules for each group or subgroup.
  • I also created one restriction rule outside of all the groups and subgroups.

Here's how the groups and restrictions look, in order:
  • Group1>1Rule
  • Restriction rule outside of all the groups.
  • Group2>0Restrictions
    • Subgroup1>11Restrictions
    • Subgroup2>12Restrictions
    • Subgroup3>14Restrictions
    • Subgroup4>15Restrictions
  • Group3>9Restrictions
  • Group4>1Restriction
  • Group 5>14Restrictions
  • Group6>1Restriction
  • Group7>3Restrictions
  • Group8>0Restrictions

So after setting this up, I tried to rearrange some of the groups' orders. Note that after arranging, I was sure to "Update" the product to save changes.

When trying to rearrange, sometimes I couldn't move one group above or below another group. For example, I'd try moving Group5 above Group3. Group3 would only let me move Group5 under its wing as a sub-group (Group3>Group5). So I'd try that as an interim, let the dust settle, and then try moving Group5 above Group3 once again. But Group5 would then not be allowed to go back as a "root" group - in any order; it was "stuck" as a sub-group. Like Pluto getting demoted to a dwarf planet - it's in the solar system, but without the status it once had.

As a test, I created a few more groups without any restrictions, and observed the same behavior. Twice, when a root group was "demoted" to a subgroup (when a root group was not allowed back in the lineup as a root group), all the groups below the demoted group became a subgroup of the demoted group. I could not move any of these "demoted" subgroups back to the root level, which is where they had started.

I also couldn't move a group downward. For example, I couldn't move Group2 below Group7. While continuing to hold the mouse button with Group2 selected, Group2 would not move back to its "root" position. Group7 (and other root groups and sub-root groups) wanted to take Group2 under its wing. Kind of like Russia wanting to take Crimea under its wing. There was nothing Group2 could do about becoming a subgroup. So I released the mouse button and the rest is history.

Next, I logged out, secretly hoping that I'd log back in and all would be well with the world (and/or solar system). When I logged back in, I discovered missing groups and restrictions… some groups had completely vanished… a digital genocide of my groups :-(

After a few minutes staring at the screen, I thought I'd let you know what's going on. I was thinking that I'd have to recreate all of the above groups and restrictions. But by the time I had initially posted in this thread and looked back at my groups, the missing groups had reappeared! They were in the same order I had saved them to before logging out.  

I hope this is enough detail to give you an understanding of what I experienced when creating groups and restrictions, and trying to rearrange them. For now, I'll keep the order of my groups and restrictions in place, with the fear that if I try to change anything, there might be a new, undesired order. And then I'd have to recreate the groups and restrictions again.


Elise Alley

Posted 04 March 2014 - 05:12 PM

Hey Tim,

Can I have you give me as specific details as possible?  That will allow me to try and replicate the issue myself.

For instance, is this happening with just one Membership product or all your Membership products?  How many products do you have?  Is Memberships the only product type you have enabled?  Does this still happen if you add the groups/restrictions when originally creating the product instead of adding and updating after the initial creation?  

If you could list out your steps, as best you can, that'd be helpful.  Even if I can't replicate it myself that way, it will be good information for the developers to look into.  




Posted 04 March 2014 - 10:42 AM

Hello Elise,

I've had the same thing that jgerst experienced happen twice now with a membership product. After creating a membership product, I've created multiple groups with content restriction rules. Next, I updated (saved) the product. I logged out, logged back in, and some of the groups had disappeared.

On a related note, I've created subgroups of groups, and added restricted content access rules to both the groups and the subgroups. The drag and drop function would not allow me to move certain groups to the levels I wanted to, so I had to recreate the hierarchies. And several different times, the hierarchy would self-adjust, skewing the hierarchies I'd set. Again, I'd have to recreate them and hope they kept their arrangements.

If there's a way you could check into this, or if you need access, just let me know, as we're going live with our membership site very soon.


Elise Alley

Posted 21 February 2014 - 06:10 PM

Hi jgerst,

There isn't a restore option in Exchange.  Instead of having to go into each page, you can add them in the actual Membership product.  I know this still isn't ideal, but it is the easier option.

I haven't had anyone report an issue like this nor have I experienced myself.   Without having direct access to the site, it's impossible at this point to say what caused it.  

Let us know if you have any additional questions.




Posted 20 February 2014 - 08:43 PM

Is there any way to restore restricted pages to a membership product? Somehow, I now see that my ASK product http://www.comm-tell.com/product/ask-learning-network/  is only showing four of the nine groups. Something happened to all the other groups which had about 50 other restricted product pages showing. I have made too many other changes to even think of going back and restoring a previous backup. What could have happened to these groups? I'm looking at many hours replacing them back.

Review the complete topic (launches new window)