Jump to content


Replying to How To Remove Hidden Store Pages From Navigation?


Post Options

  or Cancel


Topic Summary

Elise Alley

Posted 08 July 2014 - 10:38 AM

Hi K,

I think this might be an issue related to your theme.  You'll notice that it's showing multiple products at the same time:

Screen Shot 2014-07-08 at 11.19.13 AM.png

And if you click the Read More link, it refreshes the page with more products.  This would also probably explain why it's showing the pagination.  

Can you try temporarily activating one of the WordPress default themes, like Twenty Fourteen and then see if that clears up the issue?  

You can also try using the WordPress page type instead of the Exchange page type.  To do this, you'll first want to create a page named Store (or whatever you'd like it to be called).  Then go into Exchange > Settings > Pages and change the page type for the Store page to WordPress.  Select the page you just created from the dropdown menu that appears and copy the shortcode provided.  Save your settings and then paste the shortcode into your new Store page.  Once you've updated that page, check to see if it then displays properly.  

Give that a try and let us know how it goes.

Thanks,

Elise

karen

Posted 07 July 2014 - 08:05 PM

Thanks Elise. Here you go:

http://www.karengorrin.com/shop/

Elise Alley

Posted 31 March 2014 - 01:20 PM

Hi K,

I'm not sure that this is the problem.  In Exchange on the store page, all products show on one page.  

Can you please provide me with a URL where this is happening so I can take a look?  That'd be the best way for me to diagnose any issues.  

Thanks,

Elise

karen

Posted 30 March 2014 - 03:53 PM

Hi there -

I have and I'm using the Invoice Add-on in Exchange. I believe this may be causing my problem?

When a user views my store - the page navigation suggests there are more pages than actually exist. I am making a guess this is due to the fact there ARE more pages  - it's just that they contain hidden products (invoices) un-viewable to the user.

Is there a way to prevent this from happening/cause the page navigation to only reflect visible product pages?

Thanks,
K

Review the complete topic (launches new window)