Jump to content


Replying to Issue With Exchange Account Content


Post Options

  or Cancel


Topic Summary

estimley

Posted 17 April 2014 - 11:38 AM

It's okay! Probably would have helped if I'd logged in first. :)

I was using 1.4.6.2, but the devs over at LearnDash applied some tweaks and upgraded me to the latest version. I've added courses to the exchange products. I've also added download files. The transaction processes normally, the files are accessible, but not the course.

I am currently running Genesis framework with the Mocha child theme.

Here is what happens when I go through a purchase flow using Stripe (same thing occurs with PayPal): http://screencast.com/t/qncO6Ey8U

Both LearnDash & Exchange show that the products are associated properly: http://screencast.com/t/rjJf1CQ14GDu
http://screencast.com/t/UgX4XqHnCOk1

Site is https://www.flmom.com - I can give you an admin login if you need it.

Elise Alley

Posted 16 April 2014 - 04:47 PM

Hi EBM,

Sorry, it looks like I was working on my post when you posted!  :)

What version of LearnDash are you currently running?  Have you added the courses to one of your Exchange products?  

Any additional details would be helpful.

Thanks,

Elise

Elise Alley

Posted 16 April 2014 - 04:37 PM

Hi EBM,

Can you test to see if this is due to a theme conflict?  To do so, you'd temporarily activate one of the default WordPress themes like Twenty Fourteen and then see if it displays properly.

You can also test to see if this is due to a plugin conflict by temporarily deactivating all of your plugins except for Exchange and then see if it displays properly.  If it does, reactivate your other plugins one at a time, testing Exchange each time to see which plugin is creating the conflict.

Give that a try and let me know how it goes.

Thanks,

Elise

estimley

Posted 16 April 2014 - 04:32 PM

Okay. I have figured out that putting custom pages will work, but the user only receives the downloads. They aren't enrolled in the course. Any workarounds?

Posted 16 April 2014 - 01:42 PM

Hello,

I currently have a site that is running Learndash and exchange as a plugin. https://www.flmom.com

I know there is currently a conflict with LearnDash, so I downgraded the install to the version that works. Now I can process purchases, but the account pages are not showing any active formatting or links. See example screenshot here: http://screencast.com/t/fUlS9D58

Any assistance would be greatly appreciated, thanks.

Review the complete topic (launches new window)