Jump to content


Replying to Product Pages, Odd Behavior When Image Is Clicked


Post Options

  or Cancel


Topic Summary

pattyayers

Posted 08 May 2014 - 06:24 AM

Ah, excellent, I'll just turn the linked popup image off -- I didn't realize I could do that.

Thanks again for your help, Elise. Really appreciate it. Have an awesome day.

Best,
Patty

Elise Alley

Posted 07 May 2014 - 03:30 PM

Hi Patty,

That is the expected behavior.  So either a plugin or a theme was causing your earlier issue.

If you want to keep the image popup, reactivate your plugins one at a time, testing Exchange each time until you figure out which one is creating the issue.  If it's not one of the plugins, then it's your theme.

If you don't want the image popup enabled, you can go into Exchange > Settings > General Settings and in the Product Gallery Settings select No for the Enable Popup option.  

Let us know if you have any additional questions.

Thanks,

Elise

pattyayers

Posted 07 May 2014 - 02:01 PM

Hi Elise,

Ok, I have all plugins deactivated except for Exchange & add-ons, and TwentyFourteen activated, so this is just WordPress with TwentyFourteen + Exchange. I'll leave it that way until you can have a look.

There's still something funny going on. The Product Page Featured Image is clickable and opens another copy of itself in some kind of lightbox which has to be closed with the X in the top right. Any idea what's causing that, or how to fix it? Could it be something about the way I've set up the products?

Here are 2 product pages - it happens on both:
http://childsafetylibrary.com/product/book-subscription/
http://childsafetylibrary.com/product/lorem-ipsum-dolor-sit-amet/

Thanks very much in advance again,
Patty

Elise Alley

Posted 07 May 2014 - 12:54 PM

Hi Patty,

Have you tried testing for a plugin conflict?  You'd deactivate all of your plugins and then see if it works properly.  If it does, reactivate your other plugins one at a time, testing Exchange each time to see which plugin is causing the conflict.

You can also try testing for a theme conflict by temporarily activating one of the WordPress default themes like Twenty Fourteen.  

Give that a try and let us know how it goes.

Thanks,

Elise

pattyayers

Posted 07 May 2014 - 12:35 PM

Hello Support People,

I'm seeing some odd behavior on Product pages -- only those which have an image uploaded.

When I click on the image, I (barely) see an X icon flying off the screen, and then the image duplicates itself on the screen, and clicking elsewhere opens another duplicate image! This happened in 3 different browsers where I tested it.

I don't have a payment processor set up yet -- wondering if this is related to that.

Here is a Product page which shows the issue, for me, at least:
http://childsafetylibrary.com/product/lorem-ipsum-dolor-sit-amet/

Here is another:
http://childsafetylibrary.com/product/book-subscription/

Do you see the same weirdness? Any idea what's up with that?
Thanks very much in advance,

Patty
AyersVirtual.com

Review the complete topic (launches new window)