Jump to content


Replying to Exchange Update Has Broken Site Again!


Post Options

  or Cancel


Topic Summary

acri

Posted 13 June 2014 - 03:46 PM

Many thanks for saving the weekend

Glenn Ansley

Posted 13 June 2014 - 03:30 PM

It was an issue with hosts running PHP 5.3 or lower. I changed the syntax to work with that though.

Ray @sixfourweb

Posted 13 June 2014 - 03:03 PM

Glen,

The PHP problem you reference, is it that the host server is running an old/outdated version of PHP?

Glenn Ansley

Posted 13 June 2014 - 12:05 PM

Hi acri,
I apologize for this. This error was limited to some older version of PHP that we didn't test for before deploying. We have pushed an update 1.9.1 that should fix it.

If you don't have a staging server and forgot to take a backup, you can always download previous versions of the plugin on the Developers tab at wordpress.org: http://wordpress.org/plugins/ithemes-exchange/developers/

Glenn

acri

Posted 13 June 2014 - 10:20 AM

I should have known better than to update my site with exchange on a Friday.....Probably will be down all weekend
Your latest update has a php error - again
Parse error: syntax error, unexpected '[' in /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/api/cart.php on line 358

Warning: Cannot modify header information - headers already sent by (output started at /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/api/cart.php:358) in /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/lib/sessions/db_session_manager/class-db-session.php on line 129

My SIte is http://acrirlty.com/homeprotector/

You will see the white screen of death. Where can I get an old exchange version.
I am very upset, this happens way to much with this plugin.

Review the complete topic (launches new window)