Jump to content

Replying to .txt And .html Being Added To A Digital Download

Post Options

  or Cancel

Topic Summary

Elise Alley

Posted 08 August 2014 - 03:18 PM

Hi Matt,

Glad to hear that you like Exchange overall!

I can't replicate this particular issue on my test site and I've only seen this issue from one other Exchange user and it was something on their site that was automatically appending .html to their files, not just Exchange files.

I tested your site in Chrome and in Safari and it was appending a .txt extension to the file in Safari, but was downloading just fine in Chrome.  What browser are you using when this is happening?  

Can you test to see if there is a plugin that is causing this?  To do so, you'd deactivate all of your plugins except for Exchange and then see if it works correctly.  If it does, reactivate your other plugins one at a time, testing Exchange each time to see which plugin is creating the conflict.  You can also try testing for a theme conflict by temporarily activating one of the WordPress default themes like Twenty Fourteen and then see if it works correctly.

Please give that a try and let us know how it goes.  



Posted 08 August 2014 - 06:49 AM

Hi there,

I'm having an issue with a video download (1.47GB). When 'downloaded' it gets a .html extension added to the file and only downloads 55kb.

I had it hosted on my own server however it's now on dropbox, but I'm getting the same result.

I can drag the file downloaded (wrong extension) to a web browser where it will go to the drop box window and you can download it from there, but I would rather the customer get the file direct straight from the site rather than a remote url.

I had the same result with a 40kb pdf, it gained a .html extension which I can change to pdf, but unsure why it's getting this addition.

Any ideas, clues, solutions I'm missing?

Product is at: http://2020bmxmag.com.au/product/thats-whats-up-download/

coupon 499

Physical items are working a breeze and the whole simple system you have is great! Just going nuts over this little glitch.



Review the complete topic (launches new window)