Jump to content

Replying to Stripe Publishable Api Key Is Not Correct

Post Options

  or Cancel

Topic Summary

Elise Alley

Posted 07 July 2014 - 09:52 AM

Hi currentjobs,

Can you please create a new post for this issue?  It's not the same as the original post and this thread is already marked as resolved.

When you create your new post, please be sure to include your URL and any additional details you may have.  For instance, did you try testing for a plugin conflict as recommended previously?




Posted 07 July 2014 - 06:08 AM

I see this same problem.  I don't know if the underscores are just not visible or what.

Elise Alley

Posted 21 June 2014 - 08:25 AM

Hi grahamjonesuk,

The issue that Steve was having was that when he copied and pasted his API keys in, he was leaving a blank space at the end.  It was not removing the underscore and replacing it with a space.  We have not had anyone else report this issue that you are having nor have we encountered it during our testing which we do extensively before releasing.  

Please try testing for a plugin conflict.  To do so, you'd deactivate all of your plugins except for Exchange and the Stripe add-on and then see if it works properly.  If it does, reactivate your other plugins one at a time, testing Exchange each time to see which plugin is creating the conflict.

Let us know how it goes.  




Posted 21 June 2014 - 04:05 AM

I am having the same problem - yet there are NO blank spaces.

What is happening is that the Stripe add on is removing underscores and replacing them with blank spaces


Don't you test your products in advance?


Posted 20 June 2014 - 02:39 PM

Hi Elise,

I guess there was also a blank space between my ears!

Many thanks for your prompt attention.

All the best


Elise Alley

Posted 20 June 2014 - 11:13 AM

Hey Steve,

It looks like you just had a blank space at the end of each of your api keys.  I removed that and it seems to be working correctly now.

Let us know if you have any additional questions.



Elise Alley

Posted 19 June 2014 - 04:41 PM

Hi Steve,

Would you mind sending me admin log in credentials?  That way I can take a look at the set up.  You can email them to me at elise@ithemes.com or PM them to me here on the forum.  Just be sure to include a link to this thread so I know what the message is in regards to.




Posted 19 June 2014 - 11:30 AM


I have a test product here (not very pretty at the moment.)

I'me testing and very time I enter a test credit card number it throws the error "Stripe Publishable Key is not Correct". I've changed the key, double checked everything and it still throws the same error.

I note on a previous thread updating the Stripe Add on solved the problem. However in my case everythign is up to date including WP and the theme.

I'm pulling my hair out on this one - and I didn't have much to start with!

Please help before I go completely bald :-)

All the best


Review the complete topic (launches new window)