Jump to content


dirrection for creating a child theme of our own ???


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 mark

mark

    New Member

  • Members
  • Others: Builder
  • 4 posts

Posted 21 March 2011 - 07:47 AM

Is it possible to develop our own child theme to use with builder? We have an existing theme we would like to convert into a child theme. Assuming this is possible, how should we approach this? I am in need of some dirrection.

#2 Sridhar Katakam

Sridhar Katakam

    Advanced Member

  • Members
  • Others: BackupBuddy
  • 22,261 posts

Posted 21 March 2011 - 07:49 AM

Yes.

See <a class="text external" href="../../../ithemes-and-child-themes-introduction/" rel="nofollow" target="_blank">iThemes and Child Themes â introduction</a> and <a class="text external" href="../../../ithemes-and-child-themes-a-quick-tutorial-1/" rel="nofollow" target="_blank">Child Themes, a quick tutorial</a>.

Source: http://ithemes.com/codex/page/Builder_Child_Themes

Edited by Sridhar Katakam, 21 March 2011 - 02:50 AM.


#3 mark

mark

    New Member

  • Members
  • Others: Builder
  • 4 posts

Posted 21 March 2011 - 12:52 PM

I went to the "style.css" file of the theme I am trying to convert and use as a child theme for builder and edited the text using notepad and entered the following at the start of the file:

/*

Theme Name:     Builder Theme â Child Theme

Theme URI:      http://www.ithemes.com

Description:    Child theme for Builder

Author:         iThemes

Author URI:     http://www.ithemes.com

Template:       Builder

*/

/* Import Stylesheets, do not remove this line, make sure you use the correct actual folder name.

ââââââââââââââââââââ*/

@import url("../Builder/style.css");

I then updated the file in ftp and I get this message now when trying to access my website .

Fatal error: require_once() [function.require]:Failed opening required '/home2/reigrand/public_html/3circlesunltd/wp-content/themes/Builder/epanel/custom_functions.php' (include_path='.:/usr/lib64/php:/usr/lib/php') in /home2/reigrand/public_html/3circlesunltd/wp-content/themes/DeepFocus/functions.php on line 3

What am I might I be missing?

    
    


Edited by Mark Lancaster, 21 March 2011 - 10:50 AM.


#4 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 29,929 posts

Posted 21 March 2011 - 03:21 PM

Hi,

the issue is with a custom_functions.php that does not exist in Builder, and is not included in the instructions Sridhar linked to.

You could start with an empty theme folder "your_child_theme" and add a css file as instructed. Then you can activate that theme as a Builder childtheme, and add your own css, functions.php if you want, and any other theme template file (copied from the parent theme into the child theme you're creating) you wish to override.

Now I see a reference to "epanel" and "Deepfocus" and it appears a couple of things are mixed up.

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#5 Sridhar Katakam

Sridhar Katakam

    Advanced Member

  • Members
  • Others: BackupBuddy
  • 22,261 posts

Posted 21 March 2011 - 09:32 PM

Please post further Builder related support questions at http://ithemes.com/forum/index.php?/forum/64-builder/