Jump to content


My Tabber Widget has stopped working


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 nick spooner

nick spooner

    Advanced Member

  • Members
  • PipPipPip
  • 188 posts

Posted 18 April 2011 - 06:57 AM

Hey,

At www.salesorder.com we make use of a tabber widget on the penultimate section at the foot of the page. We have not made any changes to the site and for some unapparent reason the tabbed sections are now displaying as a single page.

Here is a quick video explaining the problem - http://screencast.com/t/LC1xyyWJ

Can you help?

Cheers

Nick (customer)
Rabid fan of Builder and the amazing support

#2 Josh

Josh

    Ithemes Developer

  • Moderators
  • Others: All Plugins, All Themes, BackupBuddy, Flexx
  • 2,714 posts

Posted 18 April 2011 - 09:57 AM

Hi Nick,

Thanks for the screencast. I checked and it looks like you are running into a javascript issue. So it most likely is one of your other plugins conflicting with tabber. If you would try deactivating your plugins to find the "culprit" that would be great. Then we can go from there.

Thanks!

Josh
Hey if you haven't looked at the iThemes codex check it out here!
There are some plugin walkthrough videos on our youtube channel check it out!

#3 Gwen Richardson

Gwen Richardson

    Member

  • Members
  • Others: Slideshow
  • PipPip
  • 23 posts

Posted 30 April 2011 - 01:34 PM

I too am having the tabber widget go from working perfectly fine to now stacking all 3 tab contents on to one page.

The only thing I did was add a new reservation script to the top of the page which required the following:

In the head of your HTML document, insert:

<script type="text/javascript"
src="http://www.webrezpro.com/Javascript/embed_bookingrequest.js?hotel_id=560&format=portrait&max_adults=4&max_child_age=16&max_children=4"></script>


[*]In the <BODY> tag of your document, insert:

onload="EmbedBookingRequest_onload()"


[*]At the desired location within your HTML page, insert:

<script>EmbedBookingRequest_ReturnHTML();</script>



My site with page NOT working for the tabber correctly is http://50.23.12.48/~prestige/kelowna-hotels-and-resorts-bc/

Cand you suggest a fix to resolve this please?

Thanks

Gwen

    



#4 Guest_Ronald Huereca_*

Guest_Ronald Huereca_*
  • Guests

Posted 04 May 2011 - 01:44 PM

@nick,

The problem more than likely is with the FancyBox plugin. It's hard-coding in a jQuery reference, which causes Javascript errors and results in the tabs not working.

Another issue is FancyBox's use of the $ symbol, which could cause other issues with Javascript-related plugins.

If you need an alternate lightbox plugin, I highly recommend jQuery Colorbox: http://wordpress.org/extend/plugins/jquery-colorbox/

#5 Guest_Ronald Huereca_*

Guest_Ronald Huereca_*
  • Guests

Posted 04 May 2011 - 01:51 PM

@Gwen,

I scanned the source of your site and it is definitely this line that is breaking the Javascript on your site:

[code]<pre class="brush-javascript syntax"><script type="text/javascript" src="http://www.webrezpro.com/Javascript/embed_bookingrequest.js?hotel_id=560&format=landscape&max_babies=2&access_code=on¤cy=CDN,USD,EUR"></script> 
[/code]
</pre>

Edited by Ronald Huereca, 04 May 2011 - 08:52 AM.