Jump to content


BackupBuddy working when "Wordpress address" is different from the "Site address" (General Settings)?


This topic has been archived. This means that you cannot reply to this topic.
26 replies to this topic

#21 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,407 posts

Posted 16 July 2011 - 03:54 PM

Josh said:

Quote

I will post back here when the fix is pushed

Thanks for your patience



Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#22 Gilbert Guerin

Gilbert Guerin

    Advanced Member

  • Members
  • Others: All Plugins
  • PipPipPip
  • 66 posts

Posted 17 July 2011 - 07:35 AM

Hi Pierre,

A version 2.2.6 has been apparently published.

Change history (2011.07.14) indicates:

  • importbuddy: Optional home URL is definable for migration.
  • importbuddy: Added migration of home URL usage in wp_posts table during Step 6.
Didn't have time to test it, so not sure if it solved all problems mentionned before. Will try later asap.

Gilbert

Edited by Gilbert Guerin, 17 July 2011 - 02:38 AM.


#23 Josh

Josh

    Ithemes Developer

  • Moderators
  • Others: All Plugins, All Themes, BackupBuddy, Flexx
  • 2,778 posts

Posted 18 July 2011 - 03:49 PM

Hey All,

Yes the fixes were pushed on Friday. Please let us know if you have anymore issues or questions.

Regards

Josh
Hey if you haven't looked at the iThemes codex check it out here!
There are some plugin walkthrough videos on our youtube channel check it out!

#24 Gilbert Guerin

Gilbert Guerin

    Advanced Member

  • Members
  • Others: All Plugins
  • PipPipPip
  • 66 posts

Posted 19 July 2011 - 08:20 AM

Hi Josh,

Thanks for the confirmation.

Sorry to disappoint, but after a test today with version 2.2.6 (released last Friday), I just see only very minor improvements. It still mostly have the same problems.

I am going to send you by email in few minutes a new version of the backup of a test database (V 2.2.6) and the new pdf corresponding. Please really check with these files, because I don't think it is resolved, at least with my simple test file.

In brief:

  • General Settings:
    • A Home URL: where should be the site: 'http://localhost/www.testmigrate.com': <span style="color: #ff0000">Failed: still 'http://localhost/www.testorg.com'</span>
    • A SiteUrl URL where should be wordpress files: 'http://localhost/www.testmigrate.com/wp' <span style="color: #0000ff">Passed</span>

  • Menus:
    • Links to page that should be now 'http://localhost/www.testmigrate.com/name_of_my_page' (<span style="color: #0000ff">Passed – mostly managed by WP, and after manual change of Home URL</span>)

  • Page / Article:
    • A link to a picture that should now be located in 'http://localhost/www.testmigrate.com/wp/..' <span style="color: #0000ff">Passed</span>
    • Links to page that should be now 'http://localhost/www.testmigrate.com/name_of_my_page' (<span style="color: #ff0000">Failed: links did not change</span>)

  • Widget / Serialized data:
    • A widget with serialized data that will have to be changed when migrating to a new site address (<span style="color: #ff0000">Failed: links did not change</span>, serialized data didn’t have to change – was not able to test serialized data)
    • A widget with serialized data (eg: wiki.testorg.com) that will have to be changed when migrating to a new site address (<span style="color: #ff0000">Failed:</span> no option to treat this kind of address (wiki.testorg.com) for the moment)

  • Added functionalities:
    • Could be also nice to retrieve automatically ‘index.php’ and ‘.htaccess’ at the root of the site (can be located with original value of ‘home’, and not to have to handle this manually… <span style="color: #ff0000">Failed: Not introduced in this version</span>
    • New option to replace additional strings (Functionality called: ‘any other string you would like us to change’). <span style="color: #ff0000">Failed: Not introduced in this version</span>
Gilbert

#25 Guest_Pro WP Dev_*

Guest_Pro WP Dev_*
  • Guests

Posted 19 July 2011 - 09:03 AM

Hi,

So working or not? Support says yes, Gilbert says no.

As the second was apparently previously right against all odds (and he managed to convince you), can we suppose he still has a valid point?

If it is still true, I think this guy really deserves a medal ;-). What about hiring him?

Seriously guys, the whole story during the last 2 weeks does not give really confidence in your testing method.

I guess we should be waiting before deciding to buy until Gilbert says it is finally working (shame, it seems it could be a nice product)...

the Pro WP Dev Team

Smart Devs and Processes for smart Projects

#26 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,407 posts

Posted 19 July 2011 - 09:27 AM

Hi,

for issues with BackupBuddy, please post in the BackupBuddy support forum. For feature requests, post in the Feature requests and suggestions forum.

This is a presales forum, and at the moment, this entire topic is turning into something it's not intended for (support requests, feature requests).

We will update this thread once more when issues, if any, have been ironed out. For now, it is locked.

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#27 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,407 posts

Posted 19 July 2011 - 01:10 PM

Just FYI, and to prevent even more mis-interpretations.

The fails were caused by the fact that the user was using the updated backup script, but not the updated import script. BackupBuddy performed as expected, and migrated as expected, and all is fine.

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.