Jump to content


Problem with Easy Theme and Plugin Upgrades plugin


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 Rich Foster

Rich Foster

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 July 2011 - 04:01 PM

I'm not able to upgrade to Builder 3.0.2 when the Easy Theme and Plugin Upgrades plugin is installed. I receive two error messages and the upgrade does not install.

The video in the link below demonstrates the problem. Any assistance with solving this problem would be much appreicate.

http://www.screencast.com/t/vuVuSTQCYeZe

Thanks, Rich

#2 Sridhar Katakam

Sridhar Katakam

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • 22,261 posts

Posted 24 July 2011 - 01:52 AM

You can ignore the 2nd error.

The first one is because of security restrictions imposed by your host. You are presented with FTP login info screen when you try to install any plugin (w/o using Easy Theme and Plugin Upgrades plugin), isn't it? Try contacting the host to see if they can help you with this. If that is not an option, my advice is to switch to a WordPress friendly host like HostGator.

#3 Rich Foster

Rich Foster

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2011 - 09:10 AM

Hi Sridhar,

Thanks for your repy. Actually, when I deactivate the Easy Theme and Plugin Upgrades plugin, there are no error messages. Does that imply that it is not a problem with my web host?

Thanks, Rich

#4 Sridhar Katakam

Sridhar Katakam

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • 22,261 posts

Posted 24 July 2011 - 12:55 PM

Not sure.

Have you tried searching for the exact error message (the first one) in Google?

Edited by Sridhar Katakam, 24 July 2011 - 07:56 AM.


#5 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 24 July 2011 - 03:59 PM

Rich and Sridhar [just updating with more info to since I don't have a solution myself],

This was brought up once before:
http://ithemes.com/forum/index.php?/topic/6660-trouble-updating-theme-on-a-plesk-controlled-site/

However,there was no follow-up on the post by the original poster, so the general assumption was/is that a solution or an alternate was found.

Here is the actual code which shows that error:
http://plugins.svn.wordpress.org/easy-theme-and-plugin-upgrades/tags/1.0.0/modify-installer.php

The only other thing I could find online was someone having that exact error message when they were using FF on Vista, which in my view shouldn't matter at all. However, to start diving into this more, what browser are you using, what system [again these shouldn't matter but it's good to have the info in case they do], which host and what kind of setup do you have [very important and may be the reason]?

More info on the actual WordPress FileSystem API:
http://codex.wordpress.org/Filesystem_API

Again, I don't have a solution but maybe these can spark some kind of a good idea of the next step to take.

Regards,

#6 Rich Foster

Rich Foster

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 24 July 2011 - 10:06 PM

Okay, here's what I did. I looked back at the previous post and deactivated all plugins (as Ronald suggested) except Easy Theme Upgrades

I updated an existing child theme and received the same WP Filesystem error.

I them refreshed my site, and a "Site is being Updated" message appeared.

Then I reactivated each plugin one at at time, still same "Site is Being Updated" message.

I then deactivated Easy Theme Upgrades plugin and the site refreshed okay.

Here's my setup:

Browser:Firefox 5.0; Windows 7; WordPress Version = 3.2.1; PHP Version = 5.2.12; Host = Hosting Matters

BTW, I had this same problem with the beta version of Easy Themes Upgrade plugin on more than one site.

Let me know what additional information you would like.

Thanks, Rich

Edited by Rich Foster, 24 July 2011 - 05:16 PM.