Jump to content


Tabber Widget resequencing problem ...


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 Brian Kelley

Brian Kelley

    Advanced Member

  • Members
  • Others: BackupBuddy, Webdesign
  • PipPipPip
  • 80 posts

Posted 03 August 2011 - 08:22 PM

Hi, I've run into a problem multiple times with the Tabber Widget.

Here's the situation. I create some Widget content posts; then I insert them into a three part tabber widget, for example. Then I create a second tabber widget, load it with another set of three Widget content posts/text content.

Then, the problem comes. When I go back to the first tabber widget, and modify it by adding another tabber widget tab (increasing the tabber widget from three to four tabs), then add in another Widget Content into the newly created tab in Tabber Widget #1.

The problem is that all of the other widget contents that were previously loaded into the second Tabber Widget get pushed up one, moved out of sequence. So, if previously the tab #1 in the second tabber widget was "Board of Directors", then after I modify the first tabber widget by adding a new tab, the "Board of Directors" Widget Content in the second tabber gets moved to another tab, out of sequence, and in a new tab with a different title. This is strange, and its creating a problem, for whenever I modify a tabber widget and added in some new Widget Content, all of my other tabs get out of sequence, so i have to go back to re-order the Widget Content so that it matches the names of the various tabs. over and over this has happened. It's like they are all 'in line', and when I add a new tabber widget tab somewhere in the middle of the 'line', everything gets pushed to a new tab, out of location. What can I do?

best,

Brian

#2 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 04 August 2011 - 11:46 AM

[update: another related report on this http://ithemes.com/forum/index.php?/topic/17191-tabber-randomly-switches-the-widget-content-to-another-widget-content/]

Hi Brian, :)

Thanks for posting this and for the detailed info. I just double confirmed this: it is a bug. Basically, to duplicate the issue:

1 : Create the 1st Tabber.

2 : Add 3 tabs in it [could work for any number of tabs].

3 : Add 1st Tabber as a widget with each tab having something in it.

4 : Create the 2nd Tabber.

5 : Add 3 [or any number of] tabs in it.

6 : Add 2nd Tabber as a widget with each tab having something in it.

7 : Edit 1st Tabber.

8 : Add one more tab to it.

9 : Go to the widgets section.

10 : The 2nd Tabber's tabs contents will have moved up from each respective tab.

Thanks again for bringing this up. For now as a work-around, you can simply re-organize the tabs again until we can have a fix. I'm filing this as a bug report now.

Regards,

Edited by Bes Zain, 12 August 2011 - 06:06 AM.