Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Please Note:

The iThemes offices will be closed Thursday Nov. 27 and Friday Nov. 28 for Thanksgiving.

Support will be limited, as we allow our support staff to spend some well deserved time off with their families. The iThemes Support team wishes you a great Thanksgiving weekend.

Tabber Widget Not Displaying Tab Content


This topic has been archived. This means that you cannot reply to this topic.
11 replies to this topic

#1 abannister

abannister

    Advanced Member

  • Members
  • Others: Webdesign, Toolkit
  • PipPipPip
  • 203 posts

Posted 15 September 2011 - 09:58 AM

I am working on this site using the Tabber Widget. I've populated the other tabs with filler content to see how it will lay out. I have 2 problems. The first one is the slideshow I am using is not being held within the Tabber content. The second is that the remaining tabs do not display anything. I have never used this plugin before, so please correct me if I have not populated it correctly.

Posted Image

Posted Image

#2 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 16 September 2011 - 12:30 AM

Hi Ann, :)

Thanks for posting about Tabber-Widget.

1 : For the Slideshow (clever use, btw!), put the following in your theme's css file and it will fix your issue of the 2 thumbnails not showing in the white space fully (if I'm understanding your Slideshow issue correctly).

#tab-tabber_widget-4-1{
min-height:310px;
}

That will make the first Tabber ( the "1" in tab-tabber_widget-4-1 ) have a minimum height of 310 to be able to accomodate the entire height of the Slideshow within the white background. You can play with this height as you wish, and also create additional duplicates of the above code to change the "1" to any other number, depending on the number of the tab you wanted to change anything for.

2 : Hmmmm, could you please tell me how you created the Tabber Widgets and how you put the content in them? Maybe you could take a snapshot of your 2A and 2B below?

These are the steps on how you can do them (is this how you did them too?):

2A : You go into My Theme --> Tabber Widgetssection, then create the Tabber widget there. In that same section, you create the Tab titles also.

2B : You go to your Widgets, add "Tabber Widget" to where you want Tabber-Widget to appear. Then on the same widgets page, you popular the different "Tabber" widgets already in the sidebar.

Does that make sense?

Regards,

#3 wpsmith

wpsmith

    Advanced Member

  • Members
  • Others: BackupBuddy
  • PipPipPip
  • 31 posts

Posted 18 September 2011 - 05:31 PM

---

Edited by Travis Smith, 18 September 2011 - 12:37 PM.


#4 abannister

abannister

    Advanced Member

  • Members
  • Others: Webdesign, Toolkit
  • PipPipPip
  • 203 posts

Posted 19 September 2011 - 11:40 AM

Hi Bes, Thanks for your help. I now have the slideshow contained within the tabber widget. I am also including with this post a snapshot of the widget area so you can see what I've done. I have done what you've suggested but cannot understand why the actual tabs do not work. Please let me know if you have any ideas. I appreciate all you guys do for us members.Posted Image

#5 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 19 September 2011 - 12:09 PM

Travis, your reply came out empty (sorry!). Did the reply box eat your text? :) Could you please re-add your reply again (you can edit your original reply)?


Ann,
hmmm that is very strange since from your snapshot you're doing everything right.

Q1 : What's inside the Breanna widget?

Q2 : Which version of TabberWidget are you using?

Q3 : What happens if you completely remove the Breanna Tabber option for now and have only the Jennifer content in all 3 tabs?

Q4 : What happens if you put TEXT (no Slideshow but only text) in Tab 1, Text in Tab 2 and Breanna in Tab 3?

Q5 : It could be the slideshow itself. What happens if you put in ONLY text (no slideshow, no Jennifer tab and no Breanna tab) inside the 3 tabs. What shows up then? Does it work then? What could be happening is that Slideshow is simply making Tabber Widget stop processing all info after the 1st tab.

HOWEVER, I DO see the Tab 2 contents in the source code. So Tabber Widget is loading the content now. However, the tabs aren't showing the content properly. It could be the Slideshow styling appearing within the TabberWidget styling (something the plugin wasn't designed to do).

Q6 : Could you please take a snapshot of the actual content box (where you put in the content for those 3 tabs) for Q5?
If the above don't pinpoint to anything either, I'll ask you to please email me some login info so I can go in and test around a few thing to see what could be happening.

Regards,

#6 abannister

abannister

    Advanced Member

  • Members
  • Others: Webdesign, Toolkit
  • PipPipPip
  • 203 posts

Posted 21 September 2011 - 12:15 PM

Hi Bes, Sorry for not getting back to you for a few days. Here's the latest update:

Q1 Inside the Breanna widget is a copy of the Jennifer slideshow and accordian widget.

Q2 The version of Tabber Widget is Version 1.0.5.

Q3 Basically, that is what I did to begin with, just with different names on the tab.

Q4 So, I played around with it a little bit. I added text to Jennifer and copies Jennifer's slideshow and accordian info into the Breanna tab. Then I took the text again and added it to the test tab. The first 2 function fine, the last one, nothing.

Q5 I took a new screen shot, but it does not show the actual widget content. Just let me know if you want to proceed with the login info.Posted Image

Ann

#7 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 21 September 2011 - 01:33 PM

Hi Ann,

Thanks for posting the reply! :)

Hmmmm, so from your test it seems it's DEFINITELY the Slideshow integration with TabberWidget. When you put the Slideshow in any Tab, you'll notice that any following tabs (tabs that come after that Slideshow tab) will NOT work.

Is that a correct assumption (and what you're observing too)?

I think this confirms the fact that you can show Slideshow inside a tab in Tabber Widget BUT then the remaining/following tabs will NOT show anything. I've filed this as a compatibility issue between TabberWidget and Slideshow (it will hopefully be addressed in the very near future).

Go ahead and please pm me http://ithemes.com/support/private-messaging/send/Bes+Zain/ your WP login info and I'll go in and test a few things (only to confirm this more - may/will not be able to solve anything at this point since it's mainly a compatibility thing and not an actual bug in either plugin).

OT: were you looking to have 3 Slideshows in TabberWidget (one in each Tab)?

Regards,

#8 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 21 September 2011 - 02:44 PM

Hi Ann, :)

Thanks for sending me the login info. I tested some things directly and found out some VERY interesting results.

(could you verify each please and see if you can mix and match more order/things to find out any other setup that does NOT work):

<span style="color: #008000"><span style="color: #003300">1 : If you put the Slideshow BEFORE the Accordion INSIDE any tab, EVERYTHING WORKS.</span></span>

<span style="color: #ff0000"><span style="color: #993300">2 : If you put the Accordion BEFORE the Slideshow INSIDE any tab, ANY NEXT TABS DO NOT WORK.</span></span>

<span style="color: #003300">3 : If you use ONLY Accordions in ANY tabs, EVERYTHING WORKS.</span>

<span style="color: #003300">4 : If you use ONLY Slideshows in ANYtabs, EVERYTHING WORKS.</span>

Please let me know if that's the case for you also. I can then test it some more and file it as a compatibility issue related to #2 above (and you can try to work around the issue by using 1, 3 or 4 above or a combination of those).

TEST 1 (can't duplicate this test on my side but see if it works and creates the issue # 2 above on your end): Create a NEW Accordion with NOTHING but one simple line of text for 2 Accordions. Insert that in #2 above. If the problem still exists, it's #2 the exact way I described it. OTHERWISE, it's your current Accordion contents.

Regards,

Edited by Bes Zain, 21 September 2011 - 09:55 AM.


#9 abannister

abannister

    Advanced Member

  • Members
  • Others: Webdesign, Toolkit
  • PipPipPip
  • 203 posts

Posted 21 September 2011 - 03:12 PM

Thanks Bes for taking a look. I hope you can help me understand this better. I will need to have a slideshow and the accordian located in the Tabber widget for as many students as I can fit. After your reply, I took another look into it and did not get the same results. Perhaps it is how I'm doing this. I've attached a few screen shots. If I am not setting this up right, please let me know. In the first screen shot, I've just dropped the widgets into the Tabber area. Here's what I got: as you can see, they do not align.

Posted Image

Next, I placed this into a Widget Content post with 2 columns:

Posted Image

This worked for the tab looking correct but the following widget does not appear. I've also included the widget area for you to comment on. If I can achieve the look of the 2-columns throughout the widget, I'd be very happy.

Posted Image

I'll leave it this way for you to look at and wait to hear your suggestions.

#10 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 21 September 2011 - 03:48 PM

Hi Ann, :)

Thanks for the reply.

You're doing it right, and what I said goes with it.

HOWEVER, let's stop customizing/changing anything at this moment: everything seems to be working now in your page.

This is dealing ONLY with putting shortcodes inside the Widget Content area. Ignore placing actual Slideshow/Accordion widgets inside the Tabber Widgets for now.

I just checked your page and made some edits. Everything is working.
http://www.carpediemtrainingkr.com/

Tab 1 has Jennifer Widget Content.
Jennifer Widget content has Accordion first and then slideshow. The divs in the html are closed in your editor (I noticed before a closing div was missing and added it in).

Tab 2 has Breanna Widget Content.
Breanna Widget Content has Slideshow first and then Accordion. Divs are again closed here.

Tab 3 has TEST Widget Content (test only).
Test has text only.

Everything shows/works now. If the problems comes back again after this reply of mine, we need to see exactly what you did or changed that caused it, so that we can try to duplicate it and see if it's a bug or simply a plugin compatibility issue OR even to see which exact plugin (TabberWidget? Accordion Shortcode? Slideshow shortcode?) is causing this. I can then add that info to the plugin bug or compatibility section and then in one of the future updates we can address this.

Regards,

#11 abannister

abannister

    Advanced Member

  • Members
  • Others: Webdesign, Toolkit
  • PipPipPip
  • 203 posts

Posted 21 September 2011 - 04:10 PM

Okay, thanks for the help. I'm sorry to add another question on to this but I'll eventually ask it anyhow, so here goes. Do I have to declare the height of each Tabber Widget to keep the slideshow within the desired area or is there a wrapper that can be set in the css?

#12 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 21 September 2011 - 04:55 PM

Hi Ann, :)

Thanks for the reply! No need to be sorry at all:

Add this to the css file at the very end, it will change the height of the entire tab AND also the entire TabberWidget wrapper:

#tabber_widget-4-content, #tab-tabber_widget-4-1, #tab-tabber_widget-4-2, #tab-tabber_widget-4-3
{
height: 350px;
}

Hope that helps! (added to the Codex http://ithemes.com/codex/page/Tabber_Widget#Customize_Tabber_Widget)

Regards, (let me know if anything else in the tabs gives issues â you're integrating 3 plugins together very nicely, which is something not done that much before I think in terms of using 2 DisplayBuddy plugins inside TabberWidget, so you may run into issues which haven't been tackled/addressed yet)

Edited by Bes Zain, 21 September 2011 - 11:57 AM.