Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

will Backup Buddy work on my site? - have had problems with another tool


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 Guest_Dirkje Evers_*

Guest_Dirkje Evers_*
  • Guests

Posted 18 October 2011 - 09:00 AM

Dear reader,

I am interested in Backup Buddy. However, I have tried the backup solution WP Twin earlier and I could not use it because my webhost doesnât allow me to use the following functions: <span style="color: #000000">symlink, shell_exec, exec, proc_close, proc_open, popen, system, dl, passthru, escapeshellarg, escapeshellcmd</span>. <span style="color: #0000ff">Do I need some of those functions for Backup Buddy?</span>

Your test plugin ServerBuddy did perform green on all Server Configuration parameters except for two yellows (= Warnings) on

  • Zip Methods: I have only ziparchive and pclzip available and my webhost is not willing to enable the use of exec.
  • and on PHP Magic Quotes GPC which is enabled instead of disabled. Question: does this setting absolutely need to be disabled?
Also all greens on File Permissions.

I would love to try Backup Buddy but cannot risk to loose the money on buying a plugin that I connot use.

<span style="color: #0000ff">Do you think Backup Buddy will run on my webspace, based on the above mentioned information?</span>

FYI: I live in The Netherlands and thus I have a Dutch hosting provider which is not in your Host Compatibility list.

I hope to hear from you soon,

Thanks and kind regards,

Dirkje

Edited by Dirkje Evers, 18 October 2011 - 07:00 AM.


#2 Dustin Akers

Dustin Akers

    Moderator

  • Moderators
  • Others: All Plugins, All Themes
  • 18,237 posts

Posted 18 October 2011 - 03:37 PM

Hi Dirkje,

For proper full function of BackupBuddy you need exec as a zip method. It will try to get by with using a compatibility mode, but that mode is slower and not as reliable. Compatibility mode's primary use is as a temporary solution to get the things done someone needs to for emergency situations, such as working well enough till he/she can move to a new host that has exec, really. There are still some users who use BackupBuddy for everyday use when it has to run in compatibility mode, but it is definitely best to have exec.

Normal operations still try to work. Mainly backing up, schedules, and migrate/restoring. But they have a higher chance of time out or other things going wrong due to the extra slowness and whatnot.

Magic quotes shouldn't be an issue.

Thanks,

-Akers

Edited by Dustin Akers, 18 October 2011 - 10:39 AM.

Welcome to the forums. Be sure to post your questions in the correct forum and don't forget about the new and improved search function located in the top right of the forum pages. The gear/wheel symbol next to the search box will give you more options for advanced searching. Thank you and have a nice day.
PRAISE LORD HELIX

#3 Guest_Dirkje Evers_*

Guest_Dirkje Evers_*
  • Guests

Posted 19 October 2011 - 04:00 AM

Hi Dustin,

Thanks for your immediate and helpful reply.

So the main issue here for me is the Zip Method.

  • On the FAQ page of Backup Buddy it is said: 'We recommend PHP 5.2 with command line ZIP<span style="color: #0000ff"> or </span>the ZipArchive class for optimum speed and functionality.'
  • And Serverbuddy rates the Zip Methods als follows - exec (best) > ziparchive > pclzip (worst)
So both the FAQ page of Backup Buddy ánd Serverbuddy imply that ZipArchive is the best available alternative if the exec funtion is not available. And because I do have ZipArchive available, which luckily is not rated as the worst, I think I will give it a try!

Thanks and kind regards,

Dirkje

p.s.: In the meantime I managed to disable the Magic Quotes through adding php_value magic_quotes_gpc off to the .htaccess file Posted Image

Edited by Dirkje Evers, 19 October 2011 - 12:05 AM.