Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

need some help


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 Gombos Atila

Gombos Atila

    New Member

  • Members
  • 5 posts

Posted 19 October 2011 - 09:59 PM

Hi,

I just purchased the plugin and I need some help.

All I want from this plugin is the EDIT functionality.

Can I move somehow that Edit icon eith the timer of enableb   somewhere else? I mean I know where to place the shortcode if there is one. The problem is that this plugin is good, but is breaking the design of my theme. See the pic pls.

The tweak should go here, somehow, in my comments.php file:

Posted Image

and the result should be...

Posted Image

Edited by Gombos Atila, 20 October 2011 - 03:20 AM.


#2 Gombos Atila

Gombos Atila

    New Member

  • Members
  • 5 posts

Posted 20 October 2011 - 07:19 AM

Any help?

#3 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 20 October 2011 - 04:29 PM


Hi Gombos, :)

Thank you for posting about this, and welcome to the forums!

1 : Hmmmm, currently, the default options of moving that "Edit" button are in

AEC --> Settings --> Appearance --> Display --> "Edit Interface Location"

That moves the "Edit" and "More Options" links/buttons above the actual comment, though they'll still be below the top WordPress default "Edit" button. By the way, that top default "Edit" button, shown by WordPress and not AEC, is only seen by admins and user roles who can edit comments (and not by other user roles and also not by guests).

2 : Also, you can go into AEC --> Settings --> Appearance --> Styles and enable "Style Customization" options.

After you click the "Update Style Override" button on that "Style Customization" option page, the page will refresh to show you the styles for the edit buttons that you can also play with to move the buttons around if you wish.

That's what is possible in AEC at the moment. I hope that helps!

(Also, it mayusually take up to 24 business hours to reply, by the way - we try to make it faster usually. Customer support hours and times listed on top of the forums)

Regards, and thanks again!

Bes

#4 Gombos Atila

Gombos Atila

    New Member

  • Members
  • 5 posts

Posted 20 October 2011 - 08:25 PM

Ok thanks, I managed to put the plugin somewhete where it's OK.

I have a last question. In which css file should I add a class to modily the look of the SAVE and CANCEL buttons? Add a custon style, etc.

Posted Image

Thanks.

Edited by Gombos Atila, 20 October 2011 - 03:57 PM.


#5 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 21 October 2011 - 10:43 AM

Hi Gombos, :)

Thanks for the reply. I'm glad you figured the previous placement out.



Regarding styling the SAVE and CANCEL buttons, currently it is not part of AEC ( to edit those button styles ). I've added this as a feature request for future versions. Whenever there is any update on them I'll reply here to let you know.



In the meantime, you can try to look into this on your own if possible and see if you can come up with the customization yourself. Here is one part of the code (example)






<input type="button" id="save" name="save" disabled="true" value="Save" />

<input type="button" name="cancel" id="cancel" disabled="true" value="Cancel" />









All the SAVE and CANCEL and related buttons (like "Save and Return" and "Submit Comment") are in theajax-edit-commentsviews directory in the following files:







1 : blacklist-comment.php

2 : comment-editor.php


3 : email.php
4 : request-deletion.php

Hope that helps! Regards,



Bes


Edited by Bes Zain, 21 October 2011 - 05:44 AM.


#6 Gombos Atila

Gombos Atila

    New Member

  • Members
  • 5 posts

Posted 27 October 2011 - 07:25 AM

I discovered a new error in your plugin. I have setup that admins should never see the EDIt button, nor in admin pannel or on page.

For me, the original admin, it is working. But for my other two admins, that I added some time ago, it is not working. They still can see the edit button in both places.

Why?

Posted Image

#7 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 28 October 2011 - 12:30 PM

Hi Gombos, :)

Thanks for the reply!

If I understand this feature correctly, each admin needs to set that setting to setting to No through their own account. That setting will work only for the Admin who sets it. Your other 2 admins need to do the same.

Can you try having those admins OR yourself logging into their account and setting those settings?
Each admin basically sets their own setting.

Once I have your answer and confirmation (tried it and that's how it worked from my end), I can see if that setting should be clarified OR changed completely.

Regards,

Bes

#8 Gombos Atila

Gombos Atila

    New Member

  • Members
  • 5 posts

Posted 29 October 2011 - 08:08 AM

I tested it. The setting is always ON for the admin that sets it. For the others both settings gets to default.

So, I set not to show the edit button neither in admin panel or on posts, the other two admins still see it.

If One of the other two set it like I have, I see it...

#9 Bes Zain

Bes Zain

    Member

  • Members
  • 4,268 posts

Posted 31 October 2011 - 11:21 AM

Hi Gombos, :)

Thanks for the reply. I tested this more and I can confirm this as a new bug.

Basically, change those options for any admin user to one setting. Then log in as another user, and change the settings again. The settings will get reset (lost) for the first admin.

As soon as we have a fix for this OR a workaround we'll post here, thanks!

Regards, (and thanks again for bringing this up! If you've any other questions or notice something else, you can open a new thread)

Bes