Jump to content


in progress

Login Not Working



This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 smarvel

smarvel

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 21 December 2012 - 09:28 AM

Guys, forgive me for posting this, but I've tried several times to log in to the main site -- to renew my BackupBuddy subscription -- to no avail. I've gone through the "Lost Password" procedure multiple times, but following the link in the email iThemes sends and changing my password does no good. I still can't log in to the main site, and therefore can't give you money. My original password works for the forum. NO password I've ever had works in the main site.

This is repeated behavior for the iThemes site and one I know others have experienced. If you have a final solution to this, I'd be glad to hear it. As a loyal customer, I find the time wasted trying to do what ought to be dead-simple highly inconvenient.

#2 Gerroald

Gerroald

    iThemes Support

  • Moderators
  • Others: All Plugins, All Themes, Toolkit, Webdesign
  • 3,180 posts

Posted 21 December 2012 - 10:15 AM

Hello Smarvel,

For renewal you can contact sales@ithemes.com.

If you're still having issues logging in after this please let know!

Thanks,

Gerroald

#3 Gerroald

Gerroald

    iThemes Support

  • Moderators
  • Others: All Plugins, All Themes, Toolkit, Webdesign
  • 3,180 posts

Posted 21 December 2012 - 10:20 AM

Also, I'm moving this to the Pre-Sales and Other Inquiries Forum

Thanks,

Gerroald