Jump to content


resolved

Page Problems

exchange page

13 replies to this topic

#1 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 21 August 2013 - 11:37 AM

If you go here: http://newrenaissance.us/store/
...you'll see a problem. There are no products.

None of the Exchange pages seem to be working. You can use the 'store' menu to take a look.

I did try to use the WP pages instead, and it seemed to work... but, there was no way to purchase the item... no button or link to add to cart.

Ideas?
John Burton
burtonsites.com

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 21 August 2013 - 11:53 AM

Hi John,

Can you test to see if there is a plugin conflict?  So you'd deactivate all of your plugins except for Exchange to see if it works properly.  If it does, reactivate your other plugins, one at a time, checking your Exchange links each time, to see which plugin is creating the conflict.

Also, test to see if there is a conflict with the theme you're using.  So you'd temporarily activate one of the WordPress default themes, like Twenty Twelve, and then see if it works correctly.

Can you be more specific about what's going on with the Super Widget?  When I look at the page you have linked for that issue, I see the Super Widget in your sidebar, showing that the cart is empty.  So if you can let me know what exactly is going on, I'll take a look.

Thanks,

Elise

#3 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 21 August 2013 - 11:56 AM

I actually just switched themes, and it did work after I did that. Unfortunately, I need my theme to work.
I disabled plugins too, and that was not the problem.

The super widget works... I just had white links setup in my theme. But, see my post above... when I choose to use WP pages, the cart/products show... but, there's no way to add them to the cart.
I'll switch the 'cart' to WP so you can see it. I'll leave all of the other pages Exchange.

http://newrenaissance.us/store/
John Burton
burtonsites.com

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 21 August 2013 - 01:04 PM

Hi John,

As far as I can tell right now, everything works except actually viewing the cart.  I can add items to the cart, I can buy now, etc.  So it appears the cart page is the only issue at the moment.  

Since you said that's the only one set to the WP page type, I'm wondering if that's the issue.  What happens when you leave it as an Exchange page type?

Thanks,

Elise

#5 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 21 August 2013 - 01:42 PM

I wasn't able to add anything to the cart. I couldn't find a link or button to click to add a product to the cart. If I change the store page back to exchange, it will look like all of the other exchange pages. The products will disappear and it will be all text.
John Burton
burtonsites.com

#6 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 21 August 2013 - 02:01 PM

Hey John,

Maybe I'm not understanding what the issue is.  This is what I'm seeing on your site:

When I go to the store page (you linked above):

Store.png

I clicked on the first product and can see the product as well as the options to Buy Now or Add to Cart:

Product.png

I'm able to click Add to Cart:

Add to Cart.png

My options then are to either View Cart or Buy Now.  If I click Buy Now, I don't have any issue.

Checkout.png

The problem comes when I select View Cart.

View Cart.png

But you're saying that you're still seeing all the pages like the Cart page?  Are the other plugins still deactivated?  And did you clear your browser's cache?

Now, I'm a little confused.  You said, "I'll switch the 'cart' to WP so you can see it. I'll leave all of the other pages Exchange." which makes me think all the pages I'm seeing just fine are the Exchange page type, but the Cart page is the WordPress page type and maybe that's part of the issue.  Then later said "If I change the store page back to exchange, it will look like all of the other exchange pages. The products will disappear and it will be all text."  So, I'm not really sure what page types any of the pages are set to right now!  :)

If it'd be easier, you can send me login information for your site (either by PM here on the forum or by email to elise@ithemes.com) and I'll take a look at the dashboard and see what's going on.  Just be sure to include a link to this post so I know what it's in regards to.


Thanks,

Elise

#7 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 21 August 2013 - 09:09 PM

First, when I click on "pay with paypal", I get an error:
Posted Image
The 'store' page is correct. I have it set to use a Wordpress page. Here's a screenshot:
Posted Image

Then, when I click on a product, I see something different than you do. I don't have a button to add to cart...just a box to add how many I want:
Posted Image

Then, when I click to view the cart, I see this Exchange based page:
Posted Image

All of the other Exchange pages look about the same:
Posted Image

I'll email you login info.
John Burton
burtonsites.com

#8 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 22 August 2013 - 08:02 AM

Hey John,

Your second screenshot there helps a lot.  Basically, it thinks you've already added this item to your cart (maybe you did earlier in your testing?  I'm not sure), so it's giving you a chance to edit the quantity, etc.  

It's kind of hard to see, but if you hover over to the right of the product title in that box, you'll see an x that allows you to remove that item from your cart.

Remove from cart.png

The x is grey before you hover over it when it turns blue, so it's not real easy to see.

So, basically, you can't add it to your cart because it's already in your cart.  Try clicking the x and then see if it allows you to add the item to your cart.

As for the issue with the other pages - I created a page named Cart, then went into Exchange > Settings > Pages and set the Shopping Cart page type to WordPress and selected the Cart page.  I copied the shortcode I was given then pasted that into the content area in the Cart page.  Now I can view my cart without issue.  I did this again for the Registration page and it works just fine.

I know you said earlier when you changed themes that the problems went away.  Unfortunately, it looks like you're going to have to create each page and then give the pages the WordPress page type in your Exchange Page Settings.  While that maybe tedious, you will still be able to use Exchange.

Take a look and see what I did and then let me know if you have any additional questions.

Thanks,

Elise

#9 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 22 August 2013 - 08:03 AM

Hi again John!  :)

Sorry, somehow I missed the first bit in your last post about the PayPal error.  So I just wanted to let you know I'd take a look at that too and will let you know when I have an answer for you!

Sorry again and let me know if you have questions in the meantime about anything else!

Thanks,

Elise

#10 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 22 August 2013 - 11:20 AM

Hey John,

I can't replicate the PayPal issue you're having on your site.  When I click the Pay with PayPal button, I'm taken directly to PayPal.  Are you getting this when you click that button?  Or is it when returning to the site after your payment?  Any other details you can give me would be helpful!

Thanks,

Elise

#11 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 23 August 2013 - 09:41 AM

Ok, I think we are about there. I appreciate your help. Not sure what happened with Paypal... it's working too.
A few questions. It seems that the widget is required for the ability to make a purchase, right? If I eliminated the sidebar and widget, there would be no way to add an item to the cart?

Is there a way to place a 'buy now' and 'add to cart' button next to the item on the main store page...without requiring them to 'view details'?

And, is there a way to reorder the products? You'll notice on our store page, they are out of order (starting with #4 in the series instead of #1). What if we add hundreds of products, is there a way to neatly organize them?
John Burton
burtonsites.com

#12 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 23 August 2013 - 11:03 AM

Hey John,

If you remove the Super Widget from the widget areas, the purchase buttons should then appear below the product description.  I have the Builder Market theme installed, but you can see how that should work:

Screen Shot 2013-08-23 at 10.49.27 AM.png

At this time, there isn't an option to add a purchase button on the store page; it only appears on the product page.  That has been added as a feature request, however, and you can vote for it on our Exchange Roadmap.  

The products are going to display the same way your WordPress posts do, so in order of when they are published.  There isn't another way to order them at this time.

Let me know if you have any other questions.

Thanks,

Elise

#13 johnburton

johnburton

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 24 August 2013 - 08:50 AM

Thanks! (I deleted the previous content of this post...it was an issue on my end... but couldn't figure out how to delete this post.)
John Burton
burtonsites.com

#14 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,383 posts
  • LocationOklahoma City, OK

Posted 26 August 2013 - 08:57 AM

Glad we got it all worked out, John!  Let us know if you have any other questions.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, exchange, page

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users