Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

information

Builder Views Issue With Exchange

Builder Views

13 replies to this topic

#1 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 16 October 2013 - 04:18 PM

For some reason it seems the Exchange pages are all connected with the Blog View. I'm using an extension on my Blog view which screws up Exchange. I can override this by changing every single Exchange piece's view, but that is extremely cumbersome. Is there any way to change All Exchange pages in one setting?

Site: http://sites.rosebrookmedia.com/buildmyaudience
user - ithemes
pw - rocks

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,699 posts
  • LocationOklahoma City, OK

Posted 16 October 2013 - 04:45 PM

Hi David,

The Exchange pages will take on the default layout and view assigned to it.  So, if you only have one or two pages with that particular layout/view assigned to them, it'd probably be easier to assign that layout to those pages specifically and just change your default layout so that the view doesn't affect the Exchange pages.

Let us know if you have any additional questions.

Thanks,

Elise

#3 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 16 October 2013 - 04:55 PM

That's what I'm attempting to do, but Exchange is somehow tied to doing whatever I tell the Blog View to be. So, I have a Blog & Archive View assigned to use the blog layout with the extension. Everything else is either the Default (Pages) layout or the Home page. But Exchange keeps using the Blog view. I have attempted to not use views and just assign the layout in the "Custom Layout" area on the Page the blog shows up, but that doesn't seem to be working. Here is a screenshot of my views:

Screen Shot 2013-10-16 at 5.51.13 PM.png

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,699 posts
  • LocationOklahoma City, OK

Posted 17 October 2013 - 10:38 AM

Hey David,

Would you be able to send me login information for your site so I can take a look a what's going on in the backend?  That'd probably be the easiest way for me to diagnose any issues.  You can send me the credentials here on the forum via PM or email it to me at elise@ithemes.com.  Just be sure to include a link to this post so I know what the message is in regards to.

Thanks,

Elise

#5 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 17 October 2013 - 11:11 AM

Email Sent.

#6 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,775 posts

Posted 17 October 2013 - 03:48 PM

Hi,

I am having a look from the Builder perspective, but I don't understand what exactly the issue is. Which page is not looking right? And I don't see any active Exchange products, is that intentional?

To assign a layout to an Exchange page, you should also use the Builder Views. Is that not working for you?

Posted Image

Also, make sure that a layout that you are using is not using LoopBuddy as well,
Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#7 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 17 October 2013 - 04:07 PM

Hi Ron, thanks for joining here. The issue is that the Exchange ghost-pages (there aren't any products in the store yet, but the focus for this site is the new membership option, so having pages like /account and /account/memberships work correctly is imperative) are all copying the "Blog" view that I have set in the Views. Since there is an extension set there, it completely messes up the Exchange pages. I really don't want to have to set every single one of those Exchange pages in the Views settings, I really wish there was a "All Exchange Pages" view because all of the exchange pages are messed up by the extension assigned to the blog.

#8 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,775 posts

Posted 18 October 2013 - 12:58 PM

Hi,

currently, there is currently no to assign a view to "All Exchange Pages". Having said that, there are 14 Exchange pages, and you can set each through the "Views" function in Builder. I just did by adding a test layout ("Exchange") and applied that to the "Exchange - Account" page: http://sites.rosebrookmedia.com/buildmyaudience/account/ As you can see, that works fine. So for now, you need to assign a View to each page, and you have the option(!) to assign a specific layout to each Exchange page.

I will put in a feature request to enable assigning views to all 14 layouts in one go though,

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#9 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 18 October 2013 - 01:11 PM

Hi Ronald, thanks for adding that feature request, adding 14 views is a bit cumbersome. I'll wait and see if Elise is able to figure something out when she logs into the admin area.

#10 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,775 posts

Posted 18 October 2013 - 01:23 PM

Hi,

I created a layout and added a view (for the "Account" page) from the backend of your site to see if assigning a view works properly. And it does. And unfortunately, adding 14 views is the only way to get this resolved until (and if) the feature request has been honoured. So what exactly are you expecting Elise to figure out further?

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#11 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 18 October 2013 - 01:39 PM

I suppose if there is a way to separate the Exchange default view from the Blog Posts View? It seems odd that I can't isolate it one from the other besides assigning specific Exchange views.

#12 dweuste

dweuste

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 197 posts

Posted 21 October 2013 - 05:35 PM

Well, since the only solution seems to be assigning 14 views, I've just gotten rid of using an extension for the blog and just creating a loopbuddy layout to do the same thing. Then the views don't matter and Exchange works just fine.

#13 Guest_Julie_*

Guest_Julie_*
  • Guests

Posted 02 March 2014 - 02:07 PM

I am having a similar issue but I used woocommerce.  At the time I started this site, I don't believe exchange was an option, and I have made several revisions to the site since then, but she has many sales in the woocommerce.

She wants the shopping cart to show on the product pages, but the blog should show the archives and categories.

Any help is appreciated.

http://coloradoaromatics.com

Thanks,

Julie

#14 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,699 posts
  • LocationOklahoma City, OK

Posted 05 March 2014 - 02:07 PM

Hi Julie,

I'm not quite sure I understand - are you using Exchange now?  Or are you still using Woocommerce?  

This particular forum is for Exchange.  If you're not using Exchange and are needing help with Builder, you'll want to log in and post your question in the Builder forum.  

If you're still using Woocommerce, you may want to ask your question to their support team.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: information, Builder, Views

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users