Jump to content


Stripe / Ssl Unencrypted Warning Message With Firefox

stripe ssl firefox

5 replies to this topic

#1 tonye

tonye

    Member

  • Members
  • Others: All Plugins, BackupBuddy, Exchange - Stripe
  • PipPip
  • 22 posts

Posted 06 January 2014 - 05:54 PM

Hello,

I'm receiving this firefox message when using Stripe to checkout:

"Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party."

I have an SSL installed and everything appears to go through normally, but after the payment is approved the warning message appears, then if you accept (click ok), payment is processed and purchase finalized.

You can see it on the default test page here:
https://www.alphablossom.com/product/sample-product/

It's still in test mode if you'd like to try it with one of the Stripe test credit card numbers. I'm only getting this with Firefox, other browsers process without the alert.

Thank you,
Tony

#2 tonye

tonye

    Member

  • Members
  • Others: All Plugins, BackupBuddy, Exchange - Stripe
  • PipPip
  • 22 posts

Posted 06 January 2014 - 08:05 PM

I've switched test mode off...if anyone needs it back on, please let me know and I will turn it back on.

Thank you,
Tony

#3 tonye

tonye

    Member

  • Members
  • Others: All Plugins, BackupBuddy, Exchange - Stripe
  • PipPip
  • 22 posts

Posted 07 January 2014 - 02:34 PM

I tried a transaction using the invoice plugin and have the same SSL issue, as well as this message:

No such customer: cus_3CA2Y1qOpixMX8; a similar object exists in test mode, but a live mode key was used to make this request.

The payment did not go through.

If I process this on a non-SSL page everything works as should. The SSL is really recommended even for Stripe (I know a lot of people say it's not necessary), so getting rid of it is NOT an option.

I'd really like to get this resolved if someone can help.

Thank you,
Tony

#4 tonye

tonye

    Member

  • Members
  • Others: All Plugins, BackupBuddy, Exchange - Stripe
  • PipPip
  • 22 posts

Posted 07 January 2014 - 03:49 PM

I traced the issue to the http://www.mysite/transaction/ url. I forced all /transaction/ links to use SSL and that resolved the issue. Please mark this as resolved.

#5 echoleaf

echoleaf

    Advanced Member

  • Members
  • Others: All Plugins
  • PipPipPip
  • 36 posts

Posted 16 January 2014 - 06:59 AM

@tonye: what plugin are you using to engage the SSL?

#6 tonye

tonye

    Member

  • Members
  • Others: All Plugins, BackupBuddy, Exchange - Stripe
  • PipPip
  • 22 posts

Posted 16 January 2014 - 01:23 PM

@echoleaf, I'm using WordPress HTTPS(SSL) plugin http://wordpress.org/plugins/wordpress-https/

I added /transaction/ to the URL Filters and it resolved the issue. Still doing a lot of testing, but seems to be working as should now.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange Add-on - Stripe forum.


  



Also tagged with one or more of these keywords: stripe, ssl, firefox

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users