Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Warning In Exchange Account Page


13 replies to this topic

#1 migdalia01

migdalia01

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 86 posts

Posted 19 January 2014 - 08:28 PM

Hello iThemes!

As I was getting ready to launch this site  http://proballsnapshots.com the Exchange Account page had the following PHP warning:

Warning: Creating default object from empty value in /home/proball/public_html/wp-content/plugins/ithemes-exchange/lib/pages/class.casper.php on line 55

I was able to hide it from the users with the code below in the config.php file, however that does not solve the problem.

// Hides errors from being displayed on-screen
@ini_set('display_errors', 0);

I deactivated all the plugins and activated them one by one, to no avail.  Theme and plugins are all up-to-date.

Is this something we can troubleshoot without taking the code off to un-hide the Warning?  Players are scheduled to begin playing Monday and I don’t want them to see this WARNING in their Account page as it will scare them (and the client).

In addition: Client thinks the process to "Register", "Add Address" and then go to PayPal is too complicated.  He wants the client to:
pay for the membership first then "register",  and "add address".

Is there a way to change the process?  He had several people "join" but missed the entire paying process because once you register, it says "You're now registered as (username)" and the user thinks the process is done adding the address or paying (even though there were clear instructions on the page).  Can you please shed some light on this issue.

Thank you very much for all your help.

MJ
Migdalia Johnson

#2 lewayotte

lewayotte

    iThemes Plugin Developer

  • Moderators
  • Others: Administrators
  • 47 posts

Posted 20 January 2014 - 11:42 AM

Hi Migdalia,

Do you know what version of PHP you're running? I haven't seen that warning in our development environments.

Regarding the payment workflow. There is no out-of-the-box way to modify it, it would probably take a significant amount of coding to modify the flow. However, if you're using the Super Widget, it should be pretty clear once you've registered it shows you your "cart" and payment options.

#3 migdalia01

migdalia01

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 86 posts

Posted 20 January 2014 - 10:12 PM

Quote

Do you know what version of PHP you're running? I haven't seen that warning in our development environments.

Where do I check this?

Thank you!

MJ
Migdalia Johnson

#4 digitalcult

digitalcult

    New Member

  • Members
  • Others: All Plugins
  • 3 posts

Posted 21 January 2014 - 04:16 PM

I got the same problem in a fresh WordPress 3.9 alpha installation with Exchange 1.7.14 I made today on a staging server:

Warning: Creating default object from empty value in /((absolute path))/wp-content/plugins/ithemes-exchange/lib/pages/class.casper.php on line 55

The warning only shows up in combination with PHP version 5.5.6 and 5.4.22 -- 5.3.27 works fine. (These are the three PHP versions I can chose from in my hosting.)


I tested it with a local installation of WordPress 3.8 (tested with iThemes Exchange 1.7.13 and 1.7.14) and WordPress 3.9 alpha (tested with iThemes Exchange 1.7.14) in MAMP PRO too -- PHP 5.5.3, 5.4.19 and 5.3.27 worked without a warning.

#5 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 92 posts
  • LocationWake Forest, NC

Posted 22 January 2014 - 08:31 AM

Hi,
We cannot reproduce this. Could you please try the following things, checking again between each step to see if the warning disappears? This will help us identify the source of the problem.

1) Temporarily switch to a default WordPress theme
2) Temporarily disable all other plugins one at a time, checking for the warning in between.
3) Temporarily disable any exchange add-ons.

Then let us know if/when you find the warning disappear. Thanks.

[edited - I accidentally said we 'can' when first posted. We cannot reproduce though]

#6 digitalcult

digitalcult

    New Member

  • Members
  • Others: All Plugins
  • 3 posts

Posted 22 January 2014 - 03:45 PM

1) I used Twenty Fourteen, then switched to Twenty Thirteen for testing -- warning still visible.
2) Disabled all other plugins -- warning still visible.
3a) Disabled all Exchange add-ons -- warning still visible.
3b) Disabled Exchange -- warning disappears.

… enabling Exchange again -- warning re-appears.


Uninstalled iThemes Exchange and all add-ons, re-installed Exchange 1.7.13 (no add-ons), activated plugin -- warning visible again.


[Edit: All tested with WordPress 3.9 alpha and PHP 5.5.6]

#7 migdalia01

migdalia01

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 86 posts

Posted 22 January 2014 - 05:40 PM

View PostGlenn Ansley, on 22 January 2014 - 08:31 AM, said:

Hi,
We cannot reproduce this. Could you please try the following things, checking again between each step to see if the warning disappears? This will help us identify the source of the problem.

1) Temporarily switch to a default WordPress theme
2) Temporarily disable all other plugins one at a time, checking for the warning in between.
3) Temporarily disable any exchange add-ons.

Then let us know if/when you find the warning disappear. Thanks.

[edited - I accidentally said we 'can' when first posted. We cannot reproduce though]

I tried it all and it did not disappear.  Still there!

MJ
Migdalia Johnson

#8 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 92 posts
  • LocationWake Forest, NC

Posted 23 January 2014 - 07:23 AM

Could you guys send me a username / password for your site via PM (not in this forum) so that I can see the error happening?
I am still unable to reproduce. It's not that I don't believe you, I just can't fix it until I can see it happening.

Thanks!

#9 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 92 posts
  • LocationWake Forest, NC

Posted 23 January 2014 - 07:26 AM

Migdalia,
I just created a test user from the frontend of the site but don't see the warning.

#10 migdalia01

migdalia01

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 86 posts

Posted 23 January 2014 - 09:49 AM

Hi Glenn,

As I mentioned above, I had to hide the warning from the users as my client was not very happy with it.  They are on the site 24/7 hence please let me know when is a good time for you to check it, so that I can put the site on "maintenance mode", and "un-hide" the error. I need to warn the client before or they will have a "fit".

After you logged into the site this morning, for some reason the Exchange Login page was delivering a 404 error.  I had to quickly create a Wordpress page with the Log-in.  If you can check into that while you're in the dashboard I would appreciate it.  Like I said, client is in the site 24/7 and nothing goes unnoticed.

I'll send you a message with my info.

Thanks Glenn for your help.
Migdalia Johnson

#11 digitalcult

digitalcult

    New Member

  • Members
  • Others: All Plugins
  • 3 posts

Posted 23 January 2014 - 12:08 PM

View PostGlenn Ansley, on 23 January 2014 - 07:23 AM, said:

Could you guys send me a username / password for your site via PM (not in this forum) so that I can see the error happening?

I setup a new testing environment on the same server and made an admin account for you… new subdomain, database, fresh wp install etc. etc.
Guess what? The warning didn't show up.  

I then checked the other WP install where I had the issue… And there the warning was gone too.


Posted Image

#12 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 92 posts
  • LocationWake Forest, NC

Posted 23 January 2014 - 12:57 PM

Don't you hate it when that happens. I am sure that if you were seeing it, there is probably some combination of events that will reproduce it. Please let us know if you find out what that is and we'll look into it.

Glenn

#13 migdalia01

migdalia01

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 86 posts

Posted 24 January 2014 - 08:12 PM

View PostMigdalia Johnson, on 23 January 2014 - 09:49 AM, said:

Hi Glenn,

As I mentioned above, I had to hide the warning from the users as my client was not very happy with it.  They are on the site 24/7 hence please let me know when is a good time for you to check it, so that I can put the site on "maintenance mode", and "un-hide" the error. I need to warn the client before or they will have a "fit".

After you logged into the site this morning, for some reason the Exchange Login page was delivering a 404 error.  I had to quickly create a Wordpress page with the Log-in.  If you can check into that while you're in the dashboard I would appreciate it.  Like I said, client is in the site 24/7 and nothing goes unnoticed.

I'll send you a message with my info.

Thanks Glenn for your help.

Hi Glenn!

My Login/out is no longer working.  Now the WP page does not work either...OMG!!!
Migdalia Johnson

#14 bwmtools

bwmtools

    Advanced Member

  • Members
  • Others: BackupBuddy, Toolkit
  • PipPipPip
  • 30 posts

Posted 08 March 2014 - 11:31 AM

I am currently getting this error on a newly installed site with very little plugins.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users