Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Support during Holidays:

During the Holidays (Dec. 22 - Jan. 2) our support staff will spend well-deserved time with their families and loved ones.

We can not guarantee the same level of support that you are used to.

Moderators will check in on the support forum, but response times may be longer than expected.


Your iThemes support team wishes you happy holidays!

Site Crashed After Installing Stripe


3 replies to this topic

#1 melimojo

melimojo

    New Member

  • Members
  • 5 posts

Posted 27 January 2014 - 12:56 AM

melimojodesigns.com

This is the error I've received after installing stripe. Any assistance would be greatly appreciated. Also, I can't  access my wp-admin to even uninstall the plug-in. NEED HELP PLEASE!


Fatal Error
(remove)
The site encountered a problem that it cannot recover from. Please use the following information to try to resolve the problem.
Error Message

Fatal Error: Uncaught exception 'Exception' with message 'Stripe needs the Multibyte String PHP extension.' in /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/stripe-api/lib/Stripe.php:13
Stack trace:
#0 /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/init.php(10): require_once()
#1 /home/melimojo/public_html/wp-content/plugins/ithemes-exchange/init.php(129): include('/home/melimojo/...')
#2 [internal function]: IT_Exchange->addons_init('')
#3 /home/melimojo/public_html/wp-includes/plugin.php(429): call_user_func_array(Array, Array)
#4 /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/updater/load.php(46): do_action('it_libraries_lo...')
#5 [internal function]: it_registration_list_init('')
#6 /home/melimojo/public_html/wp-includes/plugin.php(429): call_user_func_array('it_registration...', Array)
#7 /home/melimojo/public_html/wp-settings.php(331): do_action('after_setup_the...')
#8 /home/melimojo/wp-config.php(90): require_once('/home/melimojo/...')
#9 /ho in /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/stripe-api/lib/Stripe.php on line 13
Description

The iThemes Exchange - Stripe Add-on plugin code created an error that caused PHP execution to fail.
Solutions
  • Invalid code modifications can cause this problem. If you have made any modifications to the plugin, remove them and try to load the site again.
  • It is possible that this plugin's code is out of date and that an upgrade is available. Check with the plugin's author to see if an upgrade is available.
  • There may be a conflict with another plugin running on the site. Try upgrading the other plugins on the site. A plugin conflict can be ruled out by deactivating all the other active plugins on the site and checking to see if the error still occurs.
  • The iThemes Exchange - Stripe Add-on plugin may not have been fully uploaded. Uploading the plugin again could fix the issue. Important: If you do this, you will lose any modifications made to the plugin.
Error Source Details
Type Plugin Name iThemes Exchange - Stripe Add-on Version 1.1.13 Author iThemes Path /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe File lib/stripe-api/lib/Stripe.php
Other Software Details
WordPress Version 3.8.1 PHP Version 5.4.20
Full Error Details
Type Fatal Error (E_ERROR) Message Uncaught exception 'Exception' with message 'Stripe needs the Multibyte String PHP extension.' in /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/stripe-api/lib/Stripe.php:13 Stack trace: #0 /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/init.php(10): require_once() #1 /home/melimojo/public_html/wp-content/plugins/ithemes-exchange/init.php(129): include('/home/melimojo/...') #2 [internal function]: IT_Exchange->addons_init('') #3 /home/melimojo/public_html/wp-includes/plugin.php(429): call_user_func_array(Array, Array) #4 /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/updater/load.php(46): do_action('it_libraries_lo...') #5 [internal function]: it_registration_list_init('') #6 /home/melimojo/public_html/wp-includes/plugin.php(429): call_user_func_array('it_registration...', Array) #7 /home/melimojo/public_html/wp-settings.php(331): do_action('after_setup_the...') #8 /home/melimojo/wp-config.php(90): require_once('/home/melimojo/...') #9 /ho File /home/melimojo/public_html/wp-content/plugins/exchange-addon-stripe/lib/stripe-api/lib/Stripe.php Line 13 Type Description This type of error indicates that PHP cannot continue to run the code. Typical causes of this type of error are code bugs that have typos, missing or incomplete files (such as a file that was only partially uploaded), and the code using more memory than it is allowed.

Note that this message is generated by iThemes.com products when an error is encountered on the site. While an iThemes product is

#2 lewayotte

lewayotte

    iThemes Plugin Developer

  • Moderators
  • Others: Administrators
  • 50 posts

Posted 27 January 2014 - 07:13 AM

Hi Melimojo,

The first line of that error is the most important one: Fatal Error: Uncaught exception 'Exception' with message 'Stripe needs the Multibyte String PHP extension.'

It sounds like your webhost does not have PHP's mbstring module loaded or activated in PHP. You should contact them about getting it installed and activated for your website. The Stripe code requires it in order to run.

Thank you.
Lew

#3 melimojo

melimojo

    New Member

  • Members
  • 5 posts

Posted 27 January 2014 - 08:14 AM

Hi Lew,
Thanks for your early morning response. :) I've contacted my host re this issue, however, how do I get into my wp-admin in order to uninstall this plug-in? I've tried accessing the site through my ftp server, and continue to get:
authentication failed
Criticall error
could not connect to server.
I'm fairly new to all this and any more assistance would be greatly appreciated.

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 27 January 2014 - 11:36 AM

Hi melimojo,

If you are unable to access your FTP, you'll want to talk to your host about the issue.

Once you are able to log in to your FTP, to remove the add-on from your site, you'll go to wp-content/plugins/ and delete the exchange-addon-stripe folder you find there.  

Let us know if you have any additional questions.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange Add-on - Stripe forum.


  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users