Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Support during Holidays:

During the Holidays (Dec. 22 - Jan. 2) our support staff will spend well-deserved time with their families and loved ones.

We can not guarantee the same level of support that you are used to.

Moderators will check in on the support forum, but response times may be longer than expected.


Your iThemes support team wishes you happy holidays!

in progress

Incompatible With Premise Plugin For Landing Pages?

premise landing pages plugin conflict

5 replies to this topic

#1 wcholbi

wcholbi

    New Member

  • Members
  • Others: All Plugins
  • 8 posts

Posted 06 February 2014 - 04:24 PM

I was wondering if I could use Exchange for selling products/services/memberships, and another plugin (Premise by Copyblogger) for creating custom landing pages.

According to this post on the iThemes community forum, having both Premise and Exchange activated causes a fatal PHP error.

I replicated this result, and the fatal error occurs even if I don't have the Premise Membership Module activated (which would be the case if I was only going to use the landing page features).

Is there anything I can do to work around this conflict?

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 07 February 2014 - 11:08 AM

Hi wcholbi,

What error are you getting, exactly?  Is it the same as the one from the other post?  If not, what is the exact error message you're seeing?  

If it is the same error, we unfortunately don't have a workaround for it at this.  If you get me the error message, we can take a look, but I did notice that Premise is no longer available.  So we can look to see if it's an issue in Exchange that could cause problems with other plugins, but if it's an issue in Premise, there isn't much we can do.  

If you can get us additional details, we'll take a look.

Thanks,

Elise

#3 wcholbi

wcholbi

    New Member

  • Members
  • Others: All Plugins
  • 8 posts

Posted 07 February 2014 - 11:16 AM

Yes, it's the same error from the other post, in my case it looks like this:

Fatal error: Call to undefined function it_classes_load() in /home/wcholbi/wendycholbi.com/wp-content/plugins/ithemes-exchange/api/storage.php on line 73

The admin dashboard still loads just fine, but going to any page on the front end of the site shows this error on a blank screen.

I understand that you may not be able to give me any kind of workaround, but I thought it was worth it to ask. I have also inquired with Premise support (you're right that the plugin is no longer available to buy, but Copyblogger is still supporting it for now -- eventually I will have to find an alternative, and that time looks like it will be sooner rather than later).

Thanks for your quick reply.

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 07 February 2014 - 01:01 PM

Hey wcholbi,

I saw that it was just in the last couple months that they stopped selling Premise, so I thought (or at least hoped) they'd still be doing support for it at this time.  Good to know they still are for sure, though!

I'll pass this along to our developers so they can take a look.  And, when you hear back with suggestions from Premise's support team, let us know what they have to say!

Thanks,

Elise

#5 hackmanj

hackmanj

    New Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe
  • 2 posts

Posted 04 March 2014 - 01:19 PM

I also have this error and I am using Premise, any progress on this? I'd love to use exchange for my shopping cart. :)

Fatal error: Call to undefined function it_classes_load() in /home/manageds/public_html/wp-content/plugins/ithemes-exchange/api/storage.php on line 73

#6 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 31,410 posts

Posted 05 March 2014 - 03:47 PM

Just FYI, see also: http://ithemes.com/forum/topic/54619-php-fatal-error-after-installing-exchange-plugin/

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.




Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: in progress, premise, landing pages, plugin, conflict

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users