Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

in progress

Completed Order Page 404

404

12 replies to this topic

#1 Guest_James Maduk_*

Guest_James Maduk_*
  • Guests

Posted 16 February 2014 - 09:34 PM

I'm running exchange along with learndash and have a small issue with the completed orders... I  don't know if they're related to learndash or my theme so here goes.

When orders are completed from exchange a page is generated http://mydomain.com/account/confirmation/randomstringurl

This page is always 404.

Am I missing a setting?  Is it Leandash or  theme issue?

Any suggestions

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 17 February 2014 - 10:38 AM

Hi James,

It could be a theme issue.  You can try temporarily activating one of the WordPress default themes, like Twenty Fourteen, and see if it works properly.  If it does, then it's a theme issue.

You can get around this by creating a WordPress page name Confirmation (or whatever you'd like it to be).  Then, go into Exchange > Settings > Pages and find the confirmation page.  Change the page type for the confirmation page from Exchange to WordPress and select the page you created from the drop down menu.  Copy the shortcode given, save the settings then paste the shortcode into the Confirmation page that you created.  

Let us know if you have any additional questions.

Thanks,

Elise

#3 jmaduk

jmaduk

    Member

  • Members
  • Others: Exchange - Stripe
  • PipPip
  • 10 posts

Posted 26 March 2014 - 04:10 PM

Still struggling with this.    When I disable all the plugins (except ld and exchange related) a transaction will only complete when the permalinks are NOT active.  When any setting for permalinks is active the transaction never completes and goes 404.

Any other suggestions?

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 27 March 2014 - 02:42 PM

Hi jmaduk,

I'm not sure what you mean by permalinks being active or inactive.  Permalinks are always active.  Do you mean in Settings > Permalinks, the permalinks have to be set to a specific setting (for instance, Default, Post Name, Custom, etc.) to work?  If that's the case, this is an issue with the theme.  You can contact your theme developer and see if they can help or you can use whatever permalink setting it is that allows transactions to complete.  

If that's not the case, let me know what exactly the issue is and I'll see if I can help you out.

Thanks,

Elise

#5 Guest_James Maduk_*

Guest_James Maduk_*
  • Guests

Posted 01 April 2014 - 06:07 AM

I was referring to "default"  as being off :-)  As far as themes go, I have tried 3 different themes, from 3 separate vendors with the same result.

#6 jmaduk

jmaduk

    Member

  • Members
  • Others: Exchange - Stripe
  • PipPip
  • 10 posts

Posted 01 April 2014 - 06:30 AM

Default permalinks was what I meant by permalinks off.

I've testing wtih 4 differnet themes, all plugins disabled and same result.  I just tested again with the 2013 theme and permalinks set to postname.   still 404 on transaction.

Posted Image

#7 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 01 April 2014 - 09:44 AM

Hey James,

Can you please (always :)) provide us with a URL for your site so we can take a look?

Did you try using the WordPress Page Type as I'd suggested previously?

Thanks,

Elise

#8 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 02 April 2014 - 09:41 PM

Sorry about that.  I appreciate a

The tests were done with and without the WordPress confirmation page.URL= https://www.fullcontactcourses.com/?page_id=10842 http:/www.fullcontactcouses.com/  

I've tested the following variations none of which worked UNLESS the permalinks are set to default:

1. Learn Dash Plugin | LearnDash iThemes | ithemes exchange | iThemes exchange Stripe  with the confirmation page created in WP with the correct shortcode
2  Same as above with exchange default confirmation page.

I've used the following themes for both setups

Pagelines
wpforge
wp 2014
wp 2013

Right now the site is live at https://www.fullcontactcourses.com and the permalinks are set to default to keep the exchange working ..

#9 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 03 April 2014 - 02:37 PM

Hi James,

Can you try temporarily deactivating the LearnDash plugin?  We've had reports recently of a conflict.  If everything works as it should with LearnDash deactivated, you can try rolling back to an older version of LearnDash.  That has worked in the other instances.

Let me know how it goes.

Thanks,

Elise

#10 jmaduk

jmaduk

    Member

  • Members
  • Others: Exchange - Stripe
  • PipPip
  • 10 posts

Posted 03 April 2014 - 02:47 PM

It does work with learndash not active.  I'll have to test with the older version and will also post on the LD forum...  Thanks I'l let you know what I hear.

#11 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 03 April 2014 - 03:24 PM

Hey James,

We'd definitely like to hear what they come back with.  Thanks so much for checking with them.

Thanks,

Elise

#12 jmaduk

jmaduk

    Member

  • Members
  • Others: Exchange - Stripe
  • PipPip
  • 10 posts

Posted 07 April 2014 - 07:52 PM

Kind of at a standstill for now... I think you're already testing with another Learndash user and that only LearnDash 1.4.6.2 works with exchange.  If I can help in the testing let me know..
Thanks

#13 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 08 April 2014 - 11:50 AM

Hi James,

Exchange does work with LearnDash 1.4.6.2 and might with newer versions as well, but version 1.5.2.0 does create a conflict.  I just don't have access to the versions between 1.4.6.2 and 1.5.2.0.  If you have access to versions in-between the two and want to test them, you are welcome to do so.  

Let us know what you find or what the team at LearnDash tells you.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: in progress, 404

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users