Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Please Note:

The iThemes offices will be closed Thursday Nov. 27 and Friday Nov. 28 for Thanksgiving.

Support will be limited, as we allow our support staff to spend some well deserved time off with their families. The iThemes Support team wishes you a great Thanksgiving weekend.

Exchange Store Page Slug Not Working

Store exchange page slugs

9 replies to this topic

#1 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 03 March 2014 - 12:35 AM

My Exchange store was working great. Then suddenly today, when I go to my store, it shows that there is no page there (http://inspiredhealthylivingnow.com/store). I was using the "Exchange" page type and it was fine, but not anymore. I am temporarily using a wordpress page (http://inspiredhealthylivingnow.com/newstore) with the store short code on it, but it is not registering as a sale being made after payment to Paypal. None of the page slugs seem to be working now.

Also, when a customer returns from making a payment on paypal it goes to a page that doesn't exist. The customers that purchased my digital downloads today never received an email or information on how to download there product.

Please help.
Thank you,
Rob

#2 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 31,123 posts

Posted 03 March 2014 - 05:51 AM

Hi,

when you say "suddenly", do you mean absolutely nothing has been changed/added/removed that could have triggered this? No plugin updates, plugin added or removed, no WordPress updates, no theme updates? If so, can you check with your hosting provider if there have been any changes on the server?

Also, can you try generating a new htaccess file by going into wp-dashboard > Settings > Permalinks and click "save changes" (no need to change anything),

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#3 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 03 March 2014 - 08:51 AM

Okay, maybe suddenly was an overstatement.
I updated to Exchange to version 1.7.18 from version 1.7.16. My theme is not showing Permalinks on the Dashboard>Settings so I am going to try and find another way to save the permalinks. I have fallen back to version 1.7.16, it's still not working. Should I reinstall version 1.7.18?
Thanks for your help.

Rob

#4 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 03 March 2014 - 10:15 AM

Once I complete a transaction using the wordpress version of the "Store" and make a payment for an item via paypal, this is the page that it gets redirected to. However, the page isn't recognized and I get a 404 error. I don't receive an email or my download information.

http://inspiredhealthylivingnow.com/transaction/?it-exchange-transaction-method=paypal-standard-secure&paypal-standard-secure-nonce=3488f4819b&tx=0JS38632HF3735707&st=Completed&amt=0.50&cc=USD&cm=3488f4819b&item_number=

#5 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,876 posts
  • LocationOklahoma City, OK

Posted 03 March 2014 - 10:34 AM

Hi Rob,

It looks like your store page is showing correctly now.  Is your transaction completing correctly now as well?  

Let us know!

Thanks,

Elise

#6 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 03 March 2014 - 10:48 AM

No the transaction is not. 2 things. I can not display the Exchance type store, only a wordpress page store (no big deal really) but the big issue is I can accept a payment but for some reason it allows paypal to accept the transaction, but as I mentioned earlier, when it comes back from paypal it is not recognizing it as a sale. It doesn't show up in the dashboard as a sale, under the user no transaction indicated and the page it sends the customer to ( http://inspiredhealthylivingnow.com/transaction/?it-exchange-transaction-method=paypal-standard-secure&paypal-standard-secure-nonce=3488f4819b&tx=0JS38632HF3735707&st=Completed&amt=0.50&cc=USD&cm=3488f4819b&item_number=  ) is an invalid page.

Thank you,
Rob

#7 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,876 posts
  • LocationOklahoma City, OK

Posted 03 March 2014 - 03:24 PM

Hey Rob,

I apologize, you did say that you were using the WordPress page type in your original post and I missed it somehow!

Were you able to do as Ronald suggested and reset your permalinks?  You might try temporarily activating one of the WordPress default themes like Twenty Fourteen and then see if you then see the Permalinks option in your WordPress settings.  

Does the transaction show in PayPal?  And are you currently working in Sandbox mode?

Thanks,

Elise

#8 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 04 March 2014 - 12:10 AM

Hi Elise,

I have tried to get the permalinks to display on the dashboard with no luck. I have gone in and edited the permissions on the htaccess file like was suggested in another post about permalinks with no luck. I tried to use a couple different WordPress default themes, still with no luck.

Yes, when someone makes a purchase it shows in paypal (and I receive the correct payment in my paypal account) but it doesn't seem to be able to notify Exchange on the way back from PayPal. I am in live mode, not sandbox. Prior to my installing Exchange 1.7.18 the store was working perfectly, but now when I tried to go back to 1.7.16, it didn't help.

I going to keep researching how I can get my permalinks to reset, but if you have any other suggestions, they would be greatly appreciated.

Regards,
Rob

#9 Guest_Rob_*

Guest_Rob_*
  • Guests

Posted 04 March 2014 - 04:58 PM

Hi,
Thank you for the support. After going through things and turning all plugins off, I discovered that LearnDash is causing the problem. My store is working great again. I am working with ticketed support, so I will figure out what the issue with LearnDash is.

Thank you again,
Rob

#10 jmagill

jmagill

    New Member

  • Members
  • Others: All Plugins, BackupBuddy
  • 9 posts

Posted 09 October 2014 - 06:48 PM

Just in case anyone else is having the same problem …

I just updated to 1.10.6 and it caused my 'Store' page to return 'Not found'. However, a quick visit to the Permalinks page and it was fixed.

Not sure why an update would cause that. Maybe a bug? Anyway something to look into. I updated via Sync so if I hadn't gone to check the site, the store may have been 'down' for quite a while.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: Store, exchange, page slugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users