Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

resolved

Buy Now: Logged In Vs. Not Logged In

buy now

5 replies to this topic

#1 Guest_Matt_*

Guest_Matt_*
  • Guests

Posted 13 March 2014 - 12:37 PM

Hi, we're getting set to launch a site with Exchange and we've run into a wall on the product payment.

http://smartwebtoday.com/product/website-launch-formula/

Everything looks wonderful if you're logged in:
Posted Image
After clicking:
Posted Image

If you're not logged in, the purchase options change, and when you click it brings up a distorted version of the home page:
Posted Image
After clicking:
Posted Image

So I'm not sure about:
1. Why the button is different
2. Why in the world the home page is popping up if you're not logged in

I've looked through the documentation and can't seem to find any answers.

Any thoughts would be most appreciated. Thanks!

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,871 posts
  • LocationOklahoma City, OK

Posted 13 March 2014 - 02:40 PM

Hi Matt,

Can you test to see if you have a plugin conflict?  So you'd want to deactivate all of your plugins except for Exchange and any Exchange add-ons and then see if it works properly.  If it does, reactivate your other plugins one at a time, testing each time to see which plugin is creating the conflict.  You can also test to see if the conflict is theme related by temporarily activating one of the WordPress default themes like Twenty Fourteen.

Give that a try and let us know how it goes.

Thanks,

Elise

#3 Guest_Matt_*

Guest_Matt_*
  • Guests

Posted 13 March 2014 - 02:44 PM

Thanks Elise, I'll give that a shot. I should have mentioned, we're using the Builder theme. So I hope it's not a theme conflict! :)

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,871 posts
  • LocationOklahoma City, OK

Posted 13 March 2014 - 02:59 PM

Hey Matt,

Then there shouldn't be a theme conflict!  I should've looked at that closer, sorry!  :unsure:

Let me know how testing goes.

Thanks

Elise

#5 Guest_Matt_*

Guest_Matt_*
  • Guests

Posted 13 March 2014 - 03:29 PM

Success! It turns out it's a conflict with the Lead Pages Connector plugin.

Now that I know what to search for, I found this thread:
http://ithemes.com/forum/topic/55895-exchange-conflict-with-leadpages/

So, add one to the tally for that particular conflict.

FWIW, for anyone else who has this problem, setting your Lead Page to be Welcome Gate instead of Home Page solves the payment problem. It's not a perfect fix, since you only get the Lead Page on your first visit to the site, but it's something at least until (hopefully!) the conflict gets resolved in an update. I'll post this workaround on that other thread as well.

Thanks for your help Elise!

#6 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,871 posts
  • LocationOklahoma City, OK

Posted 13 March 2014 - 03:41 PM

I'm glad you got it figured out, Matt!  And thanks for sharing your workaround.

Let us know if you have any additional questions.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, buy now

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users