Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Support during Holidays:

During the Holidays (Dec. 22 - Jan. 2) our support staff will spend well-deserved time with their families and loved ones.

We can not guarantee the same level of support that you are used to.

Moderators will check in on the support forum, but response times may be longer than expected.


Your iThemes support team wishes you happy holidays!

not an error

Invoices Add-On Conflict With Theme...

exchange invoices theme

2 replies to this topic

#1 cagger

cagger

    New Member

  • Members
  • Others: Premium Exchange Addon
  • 3 posts

Posted 15 March 2014 - 09:09 AM

Hello,

Ok, so exchange with a few add-ons such as the invoices add-on appears to work great with the Twenty Fourteen theme bundled with WP. However, I have a custom theme installed, and exchange works mostly, except when viewing invoices using the invoices add-on. I know it is the theme having a conflict as it is a fresh WP install with no other plugins installed. The problem is that I cannot find out why all of exchange works except the invoices add-on with the custom theme. Are invoices using different URL techniques than anything else in the exchange plugin?

For example, visit:

http://supremewebsolutions.jibesites.com/product/test/

The product will show up. But an invoice product type will not show up, instead it redirects to the store page:

http://supremewebsolutions.jibesites.com/product/web-design-project/?client=139485436207955323c9da136b3

Here are my thoughts...

Somehow my theme is having a problem with the invoice being a hidden product type (not visible in the store) and therefore redirecting the 404 to the store page as exchange is programmed to do. Or there is an issue with the added URL parameters "?client=139485436207955323c9da136b3" at the end of the product link. Any initial thoughts or ideas?

I am not sold on the URL parameters being an issue yet as I enabled digital downloads addon and added a product download link and that worked just fine which also has ?it-exchange-download=1394895784554553246ba887624. I think there may be an issue with the theme finding the invoice as a hidden product type and then when not found, redirecting to the store page. Something about the invoices add-on is programmed to generate the links differently than the rest of exchange core and other add-ons like digital downloads.

Thanks for your help!

#2 cagger

cagger

    New Member

  • Members
  • Others: Premium Exchange Addon
  • 3 posts

Posted 15 March 2014 - 11:20 AM

Hello,

Nevermind, after messing with it for a few hours, I figured out the problem. The theme I am using has a custom post type for "client" to uplaod and display clients and their logos you have worked with on the frontend. That post type was conflicting with the client url parameter used for viewing invoices. For anyone else with a custom theme, check to see that you do not have a plugin or post type in your theme that already has a client post type. If you do, the easy thing to do is change the name for the post type to something else :)

Thanks, all resolved!

#3 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,959 posts
  • LocationOklahoma City, OK

Posted 17 March 2014 - 09:34 AM

Hi cagger,

Glad that you got it figured it out and thanks for sharing this info for other users.

Let us know if you have any additional questions.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: not an error, exchange, invoices, theme

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users