Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

in progress

Cannot Set Instruction After Purchase

Exchange Offline Payment

4 replies to this topic

#1 namcon

namcon

    New Member

  • Members
  • Others: Toolkit
  • 8 posts

Posted 04 April 2014 - 02:42 PM

Hi,

I cannot change "Instructions after purchase" for Offline Payment Add-Ons. Each time I Save Changes the message I type-in disappear and at the top display:

Please leave some instructions for customers checking out with this transaction method
Please select a valid default transaction status.

When I check on transaction page, it still appear the default settings (Thank you for your order. We will contact you shortly for payment.)

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,853 posts
  • LocationOklahoma City, OK

Posted 04 April 2014 - 05:03 PM

Hi namcon,

I can't replicate this particular issue.

Can you test to see if there is a plugin conflict?  So you'd deactivate all of your plugins except for Exchange and then see if it works properly.  If it does, reactivate your other plugins, one at a time, testing Exchange each time to see which plugin is creating the conflict.

Give that a try and then let us know how it goes.

Thanks,

Elise

#3 namcon

namcon

    New Member

  • Members
  • Others: Toolkit
  • 8 posts

Posted 05 April 2014 - 02:50 PM

Hi Elise,

I did as you said and disable all plugins, then I enable only Exchange.

I discover that I could set the message on the first time setting when I enable the plugin, but after that I tried to change it again in iThemes Exchnge > Add-ons > Offline Payments and got the same problem as before. Even after I reactivate all plugins back to normal I could change the message only by disable and reactivate Exchage plugin and set in initial setting screen after activate Exchange.

I translated features using Codestyling Localization plugin, will this effect the problem? I disabled this plugin during test but the lang file still remain.

Also I got a quick question about lang file, which will disappear every time I update the plugin. Is there a way to create a template file for lang folder like other template files? or can I put the lang folder in the theme directory directly (in exchange folder)?

Thanks in advance, please let me know if you could help in anyway.

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,853 posts
  • LocationOklahoma City, OK

Posted 08 April 2014 - 04:19 PM

Hi namcon,

Quote

Even after I reactivate all plugins back to normal I could change the message only by disable and reactivate Exchage plugin and set in initial setting screen after activate Exchange.

Did you try resetting the message while all plugins were still deactivated?  Not after reactivating?

As for the language file, anything you add directly into Exchange will be overwritten whenever you update.  You can try adding it in the "exchange" directory you created in your theme.  I'm not familiar with the plugin you're using, however, so you might also contact their developers.

Thanks,

Elise

#5 namcon

namcon

    New Member

  • Members
  • Others: Toolkit
  • 8 posts

Posted 08 April 2014 - 06:24 PM

Hi Elise,

I tried resetting the message while all plugins were deactivated and tried while plugins are activated as well. That's how I discover that I could only set the message in the first set up screen.

As for now I could set the message, though not in the normal way. I still cannot set message though Add-ons settings.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: in progress, Exchange, Offline Payment

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users