Jump to content


in progress

Super Widget Checkout Problem

Exchange Super Widget Checkout

2 replies to this topic

#1 namcon

namcon

    New Member

  • Members
  • Others: Toolkit
  • 5 posts

Posted 04 April 2014 - 02:47 PM

Hi,

In product page when I use Super Widget to Checkout it doesn't redirect to proper checkout URL.

One of my product page (http://ibeautycafe.com/product/snail-white-cream/), when click checkout with Super Widget it get's redirect to (http://ibeautycafe.com/product/snail-white-cream/transaction/) which display 404 since there no page with that URL.

Sometimes it properly gets redirect to checkout page and process could continue, but most of the time after click get 404 indicating no page.

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,235 posts
  • LocationOklahoma City, OK

Posted 04 April 2014 - 03:57 PM

Hi namcon,

Are you using the Exchange or WordPress page type (Exchange > Settings > Pages)?  If currently using the Exchange page type, try creating a confirmation page (just a regular WordPress page), then change the page type for the confirmation page to WordPress, select the confirmation page from the drop down menu and then copy the shortcode given.  Paste that shortcode into the confirmation page you created and then try another transaction once you've saved that page.

Give that a try and let us know how it goes.

Thanks,

Elise

#3 namcon

namcon

    New Member

  • Members
  • Others: Toolkit
  • 5 posts

Posted 05 April 2014 - 02:06 PM

Hi Elise,

Sorry for the late reply. I'm using WordPress page type from the beginning. Every page created by Exchange on this site is using WordPress page type.

The problem only occur if use as Widget. For now I hide the super widget for every product page and use the default super widget which display instead on product page (not widget area). Currently it's redirecting correctly to checkout page without any problem, so I speculate that the problem should be the super widget.

Please let me know if you have any fix for this.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: in progress, Exchange, Super Widget, Checkout

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users