Jump to content


resolved

Exchange Pages Are Missing All Formatting And Hyperlinks

formatting hyperlinks Exchange pages

6 replies to this topic

#1 pattyayers

pattyayers

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 17 April 2014 - 07:59 AM

Hello,

A strange issue: The Exchange pages on my site are missing all their formatting and hyperlinks. In other words, on every automatically-generated Exchange page, such as Registration, Account, etc., the text content appears as if the HTML and CSS have been stripped out.

For example:
  
AccountProfilePurchasesDownloadsFree One-Lesson MembershipTest 01 Welcome to your WeTeachWP account, Patty J. The links above allow you to view your purchases and edit your profile.

I'll send a URL by private message to Elise (or another support person who responds).

EDITED:  I just deactivated all plugins except for iThemes plugins and tested, but the problem was still there. I then switched to the TwentyFourteen theme, and the problem was not there anymore. So...

I'm using Genesis (WordPress theme framework) and my own custom child theme. When I activate Genesis directly, instead of activating my child theme, the problem is there. So my child theme isn't the problem. The problem occurs with a clean install of WordPress + Genesis + Exchange.

Have you heard of this before? Hopefully we can figure out a fix, since it will probably come up for a lot of other people too.
  
Thanks very much in advance,
Patty
AyersVirtual.com

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,505 posts
  • LocationOklahoma City, OK

Posted 17 April 2014 - 09:13 AM

Hey Patty,

It looks like you're running version 1.1.1 of the Membership Add-on.  The most recent version, however, is 1.1.4.  Can you try updating and then see if that corrects the issue?

Give that a try and let us know how it goes.

Thanks,

Elise

#3 pattyayers

pattyayers

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 17 April 2014 - 09:30 AM

Sure -- but there's no link to update it from the Admin, and it won't let me upload the updated plugin's zip file (which I've downloaded). What's the procedure? I remember seeing something about an iThemes plugin updater, but I feel like I've looked everywhere and can't find it.

EDITED: I still want to update the plugin - but meanwhile, I figured out that if I use WordPress Pages instead of Exchange Pages, I don't have the formatting problem. I'm fine with doing it that way.

Thanks,
Patty

Edited by Patricia Ayers, 17 April 2014 - 10:06 AM.


#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,505 posts
  • LocationOklahoma City, OK

Posted 17 April 2014 - 10:16 AM

Hi Patty,

Have you licensed the Membership add-on?  If you've done that, you should see the option to update.  Once you license it, it may take a few moments for the update to show that it's available.  Here's a tutorial on how to license a product in case you need it:  http://ithemes.com/tutorials/ithemes-licensing-system/

You can also do a manual update by deactivating and deleting the current version of the Membership add-on, then installing and activating the newest version that you've downloaded from your Member Panel.  Everything is stored in the database, so you shouldn't lose anything when you delete the current version, but we always recommend making a backup beforehand, just in case.  

Let me know if you have any other questions.

Thanks,

Elise

#5 pattyayers

pattyayers

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 17 April 2014 - 10:22 AM

Thank you - didn't realize that, now I have everything licensed, and the Membership plugin updated. Those Exchange Pages are still missing their formatting. But I'm happy with using WordPress pages instead, so I don't need to pursue that.

Thanks very much!!
Best,
Patty

#6 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,505 posts
  • LocationOklahoma City, OK

Posted 17 April 2014 - 10:49 AM

Hi Patty,

I'll go ahead and mark this as resolved then.  

You might, if you are so inclined and have the time, test to see if this is a theme conflict.  You'd just need to temporarily activate one of the default WordPress themes like Twenty Fourteen then see if that page shows properly.  It's not necessary for you to do this if you don't have the time or don't want to do this.  It's just always nice to know the cause of any issues!  :)

Again, I'll go ahead and mark this as resolved.  Let us know if you have any additional questions.

Thanks,

Elise

#7 pattyayers

pattyayers

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy
  • PipPipPip
  • 79 posts

Posted 17 April 2014 - 11:24 AM

Please see my edit to the first post in this thread (that was awhile ago - I didn't realize you hadn't seen it). I did a complete plugin test and a complete theme test, and the conflict is definitely between Exchange and the Genesis framework itself.

Best,
Patty



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, formatting, hyperlinks, Exchange pages

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users