Jump to content


Quantity Discount Add On- Issue Related To Activation With The Add On

Quantity discount Error with quantity discount

1 reply to this topic

#1 Guest_Lawrence_*

Guest_Lawrence_*
  • Guests

Posted 29 May 2014 - 01:45 AM

Hi all,

When I am uploading and activating the add on to my site, the site going down. There is a an error that says


Fatal Error
(remove)

The site encountered a problem that it cannot recover from. Please use the following information to try to resolve the problem.
Error Message

Fatal Error: Class 'IT_Exchange_Product_Feature_Abstract' not found in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/exchange-addon-quantity-discounts/class.quantity-discounts.php on line 9
Description

The iThemes Exchange - Quantity Discounts plugin code created an error that caused PHP execution to fail.
The code tried to use a PHP class that doesn't exist (IT_Exchange_Product_Feature_Abstract). This type of error is typically caused by a simple typo (WP_error rather than WP_Error), by trying to use a class that is provided by a plugin when that plugin is not activated, by trying to use a class before it is ready (such as trying to use a class before the code that creates it has run), or by trying to use a class that no longer exists (the class may have been removed from WordPress core or the plugin/theme that previously supplied it).
Solutions
  • Invalid code modifications can cause this problem. If you have made any modifications to the plugin, remove them and try to load the site again.
  • It is possible that this plugin's code is out of date and that an upgrade is available. Check with the plugin's author to see if an upgrade is available.
  • There may be a conflict with another plugin running on the site. Try upgrading the other plugins on the site. A plugin conflict can be ruled out by deactivating all the other active plugins on the site and checking to see if the error still occurs.
  • The iThemes Exchange - Quantity Discounts plugin may not have been fully uploaded. Uploading the plugin again could fix the issue. Important: If you do this, you will lose any modifications made to the plugin.




Could you please help me here and explain what the issue is?

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,534 posts
  • LocationOklahoma City, OK

Posted 29 May 2014 - 09:10 AM

Hi Lawrence,

Can you please (always :)) provide us with the URL where this is happening so we can take a look?  That's the best way for us to diagnose any issues.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users