Jump to content


resolved

Exchange Update Has Broken Site Again!

exchange update site php error broken plugin exchange

4 replies to this topic

#1 acri

acri

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 99 posts

Posted 13 June 2014 - 10:20 AM

I should have known better than to update my site with exchange on a Friday.....Probably will be down all weekend
Your latest update has a php error - again
Parse error: syntax error, unexpected '[' in /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/api/cart.php on line 358

Warning: Cannot modify header information - headers already sent by (output started at /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/api/cart.php:358) in /home2/acrirlty/public_html/wp-content/plugins/ithemes-exchange/lib/sessions/db_session_manager/class-db-session.php on line 129

My SIte is http://acrirlty.com/homeprotector/

You will see the white screen of death. Where can I get an old exchange version.
I am very upset, this happens way to much with this plugin.

#2 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 64 posts
  • LocationWake Forest, NC

Posted 13 June 2014 - 12:05 PM

Hi acri,
I apologize for this. This error was limited to some older version of PHP that we didn't test for before deploying. We have pushed an update 1.9.1 that should fix it.

If you don't have a staging server and forgot to take a backup, you can always download previous versions of the plugin on the Developers tab at wordpress.org: http://wordpress.org/plugins/ithemes-exchange/developers/

Glenn

#3 Ray @sixfourweb

Ray @sixfourweb

    Advanced Member

  • Members
  • PipPipPip
  • 109 posts
  • LocationNorth Carolina

Posted 13 June 2014 - 03:03 PM

Glen,

The PHP problem you reference, is it that the host server is running an old/outdated version of PHP?
SixFour Web Design creates effective WordPress websites for small businesses as well as non-profit organizations.

#4 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 64 posts
  • LocationWake Forest, NC

Posted 13 June 2014 - 03:30 PM

It was an issue with hosts running PHP 5.3 or lower. I changed the syntax to work with that though.

#5 acri

acri

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 99 posts

Posted 13 June 2014 - 03:46 PM

Many thanks for saving the weekend



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, exchange update, site php error, broken plugin exchange

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users