Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Please Note:

The iThemes offices will be closed Thursday Nov. 27 and Friday Nov. 28 for Thanksgiving.

Support will be limited, as we allow our support staff to spend some well deserved time off with their families. The iThemes Support team wishes you a great Thanksgiving weekend.

resolved

Php Error After Exchange Plugin Update

php error exchange

4 replies to this topic

#1 Ray @sixfourweb

Ray @sixfourweb

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 111 posts
  • LocationNorth Carolina

Posted 13 June 2014 - 10:22 AM

After updating Exchange, I got the following error messages:


Parse error: syntax error, unexpected '[' in /home1/XXXXXX/public_html/wp-content/plugins/ithemes-exchange/api/cart.php on line 358

Warning: Cannot modify header information - headers already sent by (output started at /home1/XXXXXX/public_html/wp-content/plugins/ithemes-exchange/api/cart.php:358) in /home1/XXXXXX/public_html/wp-content/plugins/ithemes-exchange/lib/sessions/db_session_manager/class-db-session.php on line 129


If I rename the ithemes-exchange folder, the site comes up.  I tried installing a new copy of exchange from the WordPress repo, but the same error occurred and brought down the site.  The contents of the cart.php file are below.  Line 358 contains the following text : $current_session_id   = explode( '||', $current_session_string, 2 )[0];


This site is in production and is a fundraising site. Any quick help would be greatly appreciated

*** edited by moderator, removed huge chunk of code ***

<?php
/**
* This file contains functions intended for theme developers to interact with the active shopping cart plugin
*
* The active shopping cart plugin should add the needed hooks below within its codebase.
*
* @since 0.3.7
* @package IT_Exchange
*/
/**
* Returns an array of all data in the cart
*
* @since 0.3.7
* @return array
*/
function it_exchange_get_cart_data( $key = false ) {
$data = it_exchange_get_session_data( $key );
return apply_filters( 'it_exchange_get_cart_data', $data );
}


[...]

return apply_filters( 'it_exchange_get_cart_billing_address', $cart_billing );
}

SixFour Web Design creates effective WordPress websites for small businesses as well as non-profit organizations.

#2 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 89 posts
  • LocationWake Forest, NC

Posted 13 June 2014 - 12:06 PM

Hi Ray,
I'm sorry for the mistake! We've pushed 1.9.1. This should fix your problem.

Glenn

#3 Ray @sixfourweb

Ray @sixfourweb

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 111 posts
  • LocationNorth Carolina

Posted 13 June 2014 - 03:02 PM

Glen,

Thanks for the quick turnaround. Seems to be working just fine. Will the codex (http://ithemes.com/codex/page/Exchange_Template_Updates) be updated to reflect the recent changes?
SixFour Web Design creates effective WordPress websites for small businesses as well as non-profit organizations.

#4 Glenn Ansley

Glenn Ansley

    iThemes Plugin Developer

  • Moderators
  • Others: All Plugins, All Themes, Exchange - Stripe, Toolkit
  • 89 posts
  • LocationWake Forest, NC

Posted 13 June 2014 - 03:29 PM

No template files were changed. The problem was in one of our API methods for the cart. I was using some syntax that PHP 5.3 didn't like. I just changed the syntax.

#5 Ray @sixfourweb

Ray @sixfourweb

    Advanced Member

  • Members
  • Others: Toolkit
  • PipPipPip
  • 111 posts
  • LocationNorth Carolina

Posted 13 June 2014 - 03:59 PM

Thank you for the clarification.  Have a great weekend. Happy Father's Day.
SixFour Web Design creates effective WordPress websites for small businesses as well as non-profit organizations.



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, php error, exchange

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users