Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Standard Wordpress Automatic Paragraph Missing In Exchange

automatic paragraph

2 replies to this topic

#1 ciaoweb

ciaoweb

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy, Builder
  • PipPipPip
  • 162 posts
  • LocationSwansea (U.K.)

Posted 22 June 2014 - 09:15 AM

Hello,

I have a website built with Builder that run an Exchange shopping cart.

Now the BIG problem:

My client used to have a shopping cart integrated with a theme were all products were standard WordPress posts.
He sells mainly CDs and here come the problem with Exchange... when he copy and paste the post content with a cd songs listings the automatic paragraph is not recognized by Exchange so the product description look messy.

Just to show you what I mean, look how the song listing is rendered by EC: (update: is fixed now)
http://ariwadubstore.com/product/new-test-from-robert-end-june-2014/

Now look how the same listing is rendered by the standard WordPress post:
http://ariwadubstore.com/arilp-248/

Because I have recommended EC to this client I will feel guilty if I have to force him to learn HTML and to insert <br /> for each song, it will be a real nightmare.... Can Exchange include Automatic paragraph creation?

Thanks for your help and hope to get a fast answer on this BIG problem.

Regards
Roberto Ciccolella

#2 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,738 posts

Posted 22 June 2014 - 01:27 PM

Hi Roberto,

adding the following code at the end of your child themes stylesheet style.css:

.it-exchange-product-description {
	white-space: pre-line;
}

should resolve this. The description is indeed just a plain text field. You can use the extended description, which has an editor similar to the post editor to allow more advanced editing using the front end.

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#3 ciaoweb

ciaoweb

    Advanced Member

  • Members
  • Others: All Plugins, BackupBuddy, Builder
  • PipPipPip
  • 162 posts
  • LocationSwansea (U.K.)

Posted 22 June 2014 - 02:51 PM

Hello Ronald,
Thank you so much!

That CSS line of code has fixed the issue.
My client will be very happy because he can do just copy and paste now without losing the formatting.

Have a great evening
Regards
Roberto



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users