Jump to content


resolved

Paypal Error Message – Transaction Cannot Complete

paypal paypal error message

3 replies to this topic

#1 psillari

psillari

    Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe, Premium Exchange Addon
  • PipPip
  • 15 posts

Posted 01 August 2014 - 02:44 PM

My WordPress Environment
Genesis Framework – parent theme
Dynamik Website Builder – child theme
iThemes Exchange ecommerce plugin

Site - http://dl-patterns-dev.panedexpressions.com/

Problem – The purchase transaction is not being completed once the buyer is redirected back to my site from whence the purchase was made so that the product purchased can be downloaded.

Prior to yesterday I had tested and completed a number of transactions via the paypal sandbox successfully.

Yesterday I started having a problem completing transactions.  

On the paypal side the transaction completes, the test buyer is charged, the business is credited for the sale, and the paypal notification is sent.

When redirected back to my site I receive this error message.
“Unknown error while processing with PayPal. Please check your PayPal account for any charges and try back later”

This stops the processing.  The Exchange shopping cart is not cleared, I don’t get to a Thank You page where I can then download my purchase.

Any idea what’s going on here?

Pete

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,535 posts
  • LocationOklahoma City, OK

Posted 01 August 2014 - 05:21 PM

Hi Pete,

It looks like you're running version 1.10.0 of Exchange; the most recent version is 1.10.1.  Can you try updating and see if that corrects the issue?

Also, if you try an actual payment through PayPal (not using Sandbox), does the purchase process correctly?  

Let us know whether or not updating corrects the issue.

Thanks,

Elise

#3 psillari

psillari

    Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe, Premium Exchange Addon
  • PipPip
  • 15 posts

Posted 05 August 2014 - 10:13 AM

Elise,

Updating Exchange to v1.10.1 fixed the problem.

Thanks so much for checking it out and the good advice / instruction.

Best wishes,

Pete

#4 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,535 posts
  • LocationOklahoma City, OK

Posted 05 August 2014 - 10:18 AM

Happy to have helped, Pete.  Let us know if you have any additional questions.

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved, paypal, paypal error message

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users