Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

resolved

Ithemes Exchange - Membership Add-On Is Crashing My Website



5 replies to this topic

#1 aplus

aplus

    Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe
  • PipPip
  • 21 posts

Posted 10 August 2014 - 11:49 AM

I have just confirmed that with iThemes Exchange - Membership Add-on active the website won't load the home page displays a white (blank) page and I get the attached message.
See Screenshot 2014-08-11 03.30.20.png

Any recommendations on how to fix this problem which was not occurring before I moved the site to a new hosting platform?

The website is www.adr.org.au and uses iThemes Exchange to bill monthly membership fees.

I have deleted the plugin and reinstalled a fresh version from the iThemes downloads version 1.2.4 but the same problem occurs.

Thanks

#2 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 31,356 posts

Posted 11 August 2014 - 03:40 AM

Hi,

perhaps this helps: http://ithemes.com/codex/page/ThemesFAQ#Error_message:_Out_of_memory_.28allocated_14680064.29_.28tried_to_allocate_4864_bytes.29_.28values_may_differ.29

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#3 aplus

aplus

    Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe
  • PipPip
  • 21 posts

Posted 11 August 2014 - 04:51 PM

Ronald,

Thank you for this information.  I used it last year when the site was crashing and increased the memory from 128MB to 256MB.

I have now contacted my hosting company, SiteGround and requested a server side increase from 128MB. They have replied:

Because your account is hosted on a shared server, the server's environment is commonly set up for all the users on the server and these settings can not be modified on per user basis. We can not increase the memory limit while your account is on a shared plan.

The SharedHosting limits that we have are set for optimal performance and server stability at the same time and are more than enough for the proper functionality of most applications. If your scripts require higher settings, this means that they are not suitable for the shared environment. You should contact a professional developer and have them advise you on how to work around your application's dependency on these particular settings.

In many cases, optimizing your site and its database for better performance may resolve your issue. We have prepared a useful Tutorial on Website Performance optimization.

If the basic optimization steps are not sufficient, you may also discuss the optimization of the site with a professional PHP / MySQL developer. They will be able to best assist you with the most appropriate optimization steps for your site.

Also, you may consider upgrading your hosting plan to one of our Cloud VPS plans where your account will be the only one on the server and we can adjust these settings freely.


Can you advise what is the best path to take to get Exchange operational again?

#4 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 31,356 posts

Posted 12 August 2014 - 11:44 AM

Hi,

our dev's are looking into this as it may be related to a recent update to Exchange. The current amount of memory available to your site should(!) be more than enough to run WordPress, and Exchange.

I will update as soon as I have more information,

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.


#5 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 5,955 posts
  • LocationOklahoma City, OK

Posted 12 August 2014 - 02:15 PM

Hi aplus,

We just released an update of Exchange, version 1.10.3.  Can you try updating to this new version of Exchange and see if that corrects the issue?

Let us know how it goes!

Thanks,

Elise

#6 aplus

aplus

    Member

  • Members
  • Others: BackupBuddy, Exchange - Stripe
  • PipPip
  • 21 posts

Posted 13 August 2014 - 03:12 AM

Hi Elise,
That fixed it.
Thanks



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: resolved

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users