Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

information

Child Theme - Exchange Style.css Not Applying Styles

exchange style.css child builder

3 replies to this topic

#1 solres

solres

    New Member

  • Members
  • Others: Toolkit
  • 4 posts

Posted 31 August 2014 - 01:49 AM

Hi,

I have been playing with exchange for the first time and I am having trouble getting the customer menu buttons to change to the required colour.
I found your information about creating an "Child-Theme"/exchange/style.css but this doesn't appear to have an affect. Maybe I am missing something.

test site = mhs.jonathonbosel.com

Any help would be great.

Cheers

Jonathon

#2 solres

solres

    New Member

  • Members
  • Others: Toolkit
  • 4 posts

Posted 31 August 2014 - 01:55 AM

To Clarify, I am referring to the customer menu buttons that are visible when logged in.. ie account, profile, purchases, downloads.
They are currently set to #50130C when highlighted or #862A1F when not highlighted.

Even though it is not recommended, I have changed the "background:" in the style.css file under the builder theme (not the child) to #338841 to try and achieve anything and still no joy.

#3 Gerroald

Gerroald

    iThemes Support

  • Moderators
  • Others: All Plugins, All Themes, Toolkit, Webdesign
  • 3,545 posts
  • LocationiThemes World HQ

Posted 02 September 2014 - 05:39 PM

Hey Jonathon,

Have you tried adding "!important" to your CSS rules? If not, give that a try and let me know if it helps!

Thanks,

Gerroald

#4 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 30,849 posts

Posted 03 September 2014 - 04:55 AM

Hi,

Firefox shows the following:

Posted Image


so

.builder-module-block .it-exchange-customer-menu a {
	background-color: red;
	color: blue;  
}

.builder-module-block .it-exchange-customer-menu a:hover {
	background-color: blue;
	color: red;  
}

.builder-module-block .it-exchange-customer-menu .current a {
	background-color: pink;
  color: green;
}

should do the trick, see:

Posted Image

Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.




Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: information, exchange, style.css, child, builder

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users