Jump to content


Trouble updating theme on a Plesk controlled site


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 Dave West

Dave West

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 16 August 2010 - 03:28 PM

I uploaded the "Easy Theme and Plugin Upgrades Plugin" and activated and everything seems to be okay with the plug-in installation. Then I go to Appearance/Themes/Install Themes/Browse and browse to the new Builder.zip on my harddrive. Then select "Yes" to the Upgrade existing theme? question. Then press "Install Now".

Then the next screen asks for the following:

Connection Information

Unable to initialize WP_Filesystem. Will not proceed with the upgrade.

To perform the requested action, WordPress needs to access to your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.

Hostname  

FTP Username  

FTP Password  

Connection Type  

Connection Type FTP FTPS (SSL)

Proceed (Proceed is a Button)

When this screen comes up all the information is pre-filled and works for other operations when it comes up and the proceed button is pressed.

But in this case when the "Proceed" button is pressed the following message appears:

Installing Theme from uploaded file: Builder2.zip

You must select "Yes" from the "Upgrade existing theme?" dropdown option in order to upgrade an existing theme. Try again.

Unpacking the package

Installing the theme

Destination folder already exists. /httpdocs/wp-content/themes/Builder/

Theme install failed.

Tried about 5 times with the same result. And I'm sure that Yes was selected for the Upgrade existing theme question.

I also checked all the directories permissions and they are at 755.

Edited by Dave West, 16 August 2010 - 10:36 AM.


#2 Ronald

Ronald

    Forum Admin

  • Administrators
  • Others: All Plugins, All Themes, Moderators, Webdesign
  • 29,998 posts

Posted 16 August 2010 - 04:32 PM

Hi,

- does this occur when you have another theme active as well?

- deactivate all plugins and see if this still happens, then activate one by one to see when (if at all) the issue occurs

Alternatively, you can use "plain" FTP to upload the theme files to your site,

let us know,
Ronald

Join the iThemes Builder Community on Google+.



To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. Please also read the forum guidelines.



When asking your question/posting your request on the forum, please be as concise and specific as possible. The shorter your request, the more to the point, the more specific, the easier it will be for us to try and help out.