Jump to content


Welcome to the forum:

Welcome to the iThemes, PluginBuddy and WebDesign.com forum. We've created several tutorial video's to help you get you started with using the forum, please check them out!

Also take note of the forum guidelines.


Support hours:

Our moderators actively respond to forum support requests during normal business hours which are Monday-Friday, 8am - 5pm Central Standard Time, typically within one business day. Although some moderators choose to work during the weekends, we can not guarantee immediate attention to your requests. Thanks for understanding.

What is included with support:

Premium support includes theme/plugin issues such as: bugs encountered under normal operation, how to use basic features, basic WordPress help, and basic help with customization (meaning we point you to resources and will help in more depth as time allows). More information.

Tabber 1.04 & Twitter


This topic has been archived. This means that you cannot reply to this topic.
13 replies to this topic

#1 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 04 December 2010 - 12:42 AM

I'm running a test site with:

- WP 3.02

- Genesis 1.4

- Tabber 1.04

- no other plugins activated

If I grab the Twitter search widget code from Twitter's site and put it in a text widget, the tabs don't work in Chrome and Safari, but do work fine in Firefox. The same thing can be observed if I use a Twitter search plugin, like Arpit Shah's Twitter Goodies.

Anyone have any recommendations for how to fix this?

Thanks in advance...

#2 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 13 December 2010 - 09:48 AM

We just updated this plugin and if it was working for you before the update that would be important for us to know.

Here is a link to download the previous version if you would like to try using it instead.

<a  href="http://downloads.wordpress.org/plugin/tabber-widget.1.0.3.zip" rel="nofollow" target="_blank">http://downloads.wordpress.org/plugin/tabber-widget.1.0.3.zip</a>

Edited by skylermoore, 13 December 2010 - 03:51 AM.


#3 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 13 December 2010 - 02:26 PM

It didn't work on 1.0.3 and doesn't work on 1.0.4.

Any sense of how complicated it might be to fix?

#4 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 13 December 2010 - 05:15 PM

I haven't used either of those plugins before so I'm not sure what could be causing the issues with tabber widget.

I'm not sure if this will help but you may want to try placing the twitter widgets in the first tab to see if that makes a difference.

The change that we just made in the last update was so that links that start with # in the tabber widget link correctly.

#5 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 13 December 2010 - 11:05 PM

The Twitter widget is not in a tab, it is just on the same page in a non-Tabber widget area.

The problem occurs not with 1 specific Twitter plugin, but with the script from Twitter itself plus other Twitter widgets I've tried. I suspect it is a problem for anyone using Tabber + a Twitter search function, which is extrememly popular.

Since it occurs with Twitter's own widget, is this a conflict with their javascript?

#6 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 14 December 2010 - 11:42 AM

That is a very strange issue when I was looking at your site in IE8 it pulled up debuging when I clicked a tab in tabber widget. What was weird was that it was saying there was an issue with the wordpress core jquery file.

Do you know if there have been any changes made to the wordpress jquery file on your site?

#7 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 14 December 2010 - 03:16 PM

No, certainly nothing I (or anyone else) did. The only way the standard jQuery could have been modified is by a WP update or plugin install. I can try doing a clean download to my desktop and FTP'ing a fresh jQuery to see if that makes a difference.

Also, FWIW, the domain I linked to is really just a test domain that I used to isolate the problem. You can visit the domain at my email address, www.aidemocracy.org, to see the problem as well, but there is a lot more going on with widgets, plugins, that I removed from the test domain to isolate the problem.

I'll post back once I've checked jQuery.

#8 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 14 December 2010 - 05:56 PM

I checked /wp-includes/js/jquery/jquery.js and compared it to a fresh download of WP 3.0.3, and there's nothing wrong with that file.

If you're referring to another jquery file, let me know and I'll check.

You mentioned you checked in IE 8. Keep in mind that the tabs work fine in IE 8. You will only see the problem in Chrome or Safari.

#9 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 15 December 2010 - 09:57 AM

If you would like the scripting errors to appear in ie8 then you can change your browser settings.

Go to tools -> internet options -> advanced tab -> under browsing check the "Display a notification about every script error" checkbox.

After you change that setting you get a notification when you click one of the tabs in tabber widget on your site.

I'm not sure why those 2 plugins don't work together on the same page, have you tried any other tab plugins with the twitter plugins you are using?

#10 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 15 December 2010 - 03:48 PM

On my current desktop, I have IE 9, not IE 8, and I don't see any script errors, even after clicking on 1 of the tabs.

I've looked at other tab plugins, but not tried them, because Tabber is one of the few that allows widgets in tabs.

Do you know of any site that is using Tabber where there is a Twitter search widget of any kind on the page? If it is a problem for anyone doing a Twitter search, it would seem like it would be important to fix it, just because of how big Twitter is.

#11 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 16 December 2010 - 10:17 AM

Did you enable the script error display for your browser?

I will download the twitter search plugin to see if I can create the same issue on my test site and let you know what I find.

#12 skylermoore

skylermoore

    Member

  • Members
  • Others: All Themes, BackupBuddy, All Plugins, DisplayBuddy, ThumbsUp
  • 2,141 posts

Posted 16 December 2010 - 03:01 PM

I ran the twitter search widget on my site with the tabber widget and it does break tabber widget for some reason.

I can notify the developer of tabber widget so that he know what is going on but for now you may want to try using some wordpress twitter search plugins.

Thanks for your patience sorry this issue doesn't have an easy fix.

#13 Guest_Bill_*

Guest_Bill_*
  • Guests

Posted 16 December 2010 - 11:57 PM

Thanks, Skyler.

I've tried a number of WP twitter search plugins, and they all break Tabber.

If I find one that works, I'll post back, but hopefully the Tabber plugin gets fixed. Some people are just really big on this thing called Twitter.

What's tough on my site is that although it works fine in Firefox and IE 9, Tabber breaks in Chrome and Safari, which accounts for 40% of our traffic. We want to keep Tabber and Twitter, but one of those T's is going to have to be sidelined for a bit until this gets sorted out.

#14 Guest_lucian_*

Guest_lucian_*
  • Guests

Posted 01 March 2011 - 05:56 PM

I have the same problem.

Right now I'm using thisas an interim solution. It's the closest thing working (doesn't break tabber), but not very reliable. Still looking for a solution.