Jump to content


Better, More Convenient, Private Support for Your iThemes Products Is Here.


We're moving support away from the forum and in to private tickets - Log In to Get Support Here


Note: any currently open support threads in the community forum will stay open while we resolve them.

in progress

.txt And .html Being Added To A Digital Download



1 reply to this topic

#1 Guest_Matt_*

Guest_Matt_*
  • Guests

Posted 08 August 2014 - 06:49 AM

Hi there,

I'm having an issue with a video download (1.47GB). When 'downloaded' it gets a .html extension added to the file and only downloads 55kb.

I had it hosted on my own server however it's now on dropbox, but I'm getting the same result.

I can drag the file downloaded (wrong extension) to a web browser where it will go to the drop box window and you can download it from there, but I would rather the customer get the file direct straight from the site rather than a remote url.

I had the same result with a 40kb pdf, it gained a .html extension which I can change to pdf, but unsure why it's getting this addition.

Any ideas, clues, solutions I'm missing?

Product is at: http://2020bmxmag.com.au/product/thats-whats-up-download/

coupon 499

Physical items are working a breeze and the whole simple system you have is great! Just going nuts over this little glitch.

Cheers,

Matt

#2 Elise Alley

Elise Alley

    iThemes Support

  • Administrators
  • Others: All Plugins, All Themes, Members, Moderators, Toolkit, Webdesign
  • 6,636 posts
  • LocationOklahoma City, OK

Posted 08 August 2014 - 03:18 PM

Hi Matt,

Glad to hear that you like Exchange overall!

I can't replicate this particular issue on my test site and I've only seen this issue from one other Exchange user and it was something on their site that was automatically appending .html to their files, not just Exchange files.

I tested your site in Chrome and in Safari and it was appending a .txt extension to the file in Safari, but was downloading just fine in Chrome.  What browser are you using when this is happening?  

Can you test to see if there is a plugin that is causing this?  To do so, you'd deactivate all of your plugins except for Exchange and then see if it works correctly.  If it does, reactivate your other plugins one at a time, testing Exchange each time to see which plugin is creating the conflict.  You can also try testing for a theme conflict by temporarily activating one of the WordPress default themes like Twenty Fourteen and then see if it works correctly.

Please give that a try and let us know how it goes.  

Thanks,

Elise



Reply to this Topic


ATTENTION
If this topic is marked RESOLVED or INFORMATION, or if you are NOT experiencing EXACTLY the same issue, please start a new topic to provide the details of your problem. If the solution provided doesn't work for you, you should start a new topic. If you feel this thread contains relevant information, you may include a link to it in your new topic. To ensure that we can process your support request efficiently, ALWAYS include a link to your site, and/or the page your request is related to. When posting your question or request on the forum, please be as concise and specific as possible. The shorter and more to the point you can make your request, the better.

For BackupBuddy related issues, be sure to include the status log from your most recent backup.

CLICK HERE to start a new topic in the Exchange ecommerce plugin forum.


  



Also tagged with one or more of these keywords: in progress

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Better, More Convenient, Private Support for Your iThemes Products Is Here.


We're moving support away from the forum and in to private tickets - Log In to Get Support Here


Note: any currently open support threads in the community forum will stay open while we resolve them.